Subject: [alpine-aports] [PATCH 1/2] testing/py3-pytest-flake8: new APKBUILD

From: Drew DeVault <[email-masked]>
Date: Sun, 30 Jun 2019 14:24:30 -0400

---
 testing/py3-pytest-flake8/APKBUILD | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
 create mode 100644 testing/py3-pytest-flake8/APKBUILD

diff --git a/testing/py3-pytest-flake8/APKBUILD b/testing/py3-pytest-flake8/APKBUILD
new file mode 100644
index 0000000000..be843aeaf2
--- /dev/null
+++ b/testing/py3-pytest-flake8/APKBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Drew DeVault <[email-masked]>
+pkgname=py3-pytest-flake8
+_pyname=pytest-flake8
+pkgver=1.0.4
+pkgrel=0
+pkgdesc="pytest plugin for efficiently checking PEP8 compliance"
+url="https://pypi.org/project/pytest-flake8/"
+arch="noarch"
+license="3-Clause-BSD"
+depends="py3-pytest py3-flake8"
+makedepends="py3-setuptools"
+_pypiprefix="${_pyname%${_pyname#?}}"
+source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
+builddir="$srcdir/$_pyname-$pkgver"
+
+build() {
+	python3 setup.py build
+}
+
+check() {
+	python3 setup.py test
+}
+
+package() {
+	python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="39ac19f3216386dc33b7c3c7c12a026751bb636d140340eb9585e161292d74f587c3a032125380bd12834e841172bf47652c19036bd06d493abd11cefe428429  pytest-flake8-1.0.4.tar.gz"
-- 
2.22.0

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Drew DeVault <[email-masked]>
Date: Sun, 30 Jun 2019 14:24:31 -0400

---
 testing/py3-pytest-isort/APKBUILD | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
 create mode 100644 testing/py3-pytest-isort/APKBUILD

diff --git a/testing/py3-pytest-isort/APKBUILD b/testing/py3-pytest-isort/APKBUILD
new file mode 100644
index 0000000000..6faaf10d83
--- /dev/null
+++ b/testing/py3-pytest-isort/APKBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Drew DeVault <[email-masked]>
+pkgname=py3-pytest-isort
+_pyname=pytest-isort
+pkgver=0.3.1
+pkgrel=0
+pkgdesc="pytest plugin to check import ordering using isort"
+url="https://pypi.org/project/pytest-isort/"
+arch="noarch"
+license="3-Clause-BSD"
+depends="py3-pytest py3-isort"
+makedepends="py3-setuptools"
+_pypiprefix="${_pyname%${_pyname#?}}"
+source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
+builddir="$srcdir/$_pyname-$pkgver"
+
+build() {
+	python3 setup.py build
+}
+
+check() {
+	export PYTHONPATH="$(pwd)"
+	pytest-3
+}
+
+package() {
+	python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="2fd39108a6acacf18ce68bb537d2adeb4ff7cd8ea4c9611e5312edea5a0bc4841111ffb544318aa7b3bebe38e9f4744f07a45b2ebcbf872f79003b249ee115ca  pytest-isort-0.3.1.tar.gz"
-- 
2.22.0

---