Subject: [alpine-devel] comments on setup-apkrepos

From: Natanael Copa <[email-masked]>
Date: Mon, 28 Feb 2011 16:21:39 +0100

Hi,

 Nice work that has been done on setup-apkrepos!

 I have a few minor comments.

 1) Try avoid == operator.
 Its bash specific, and even if it is implemented in busybox ash, its no 
 guarantee it will in future.

 replace:

   if [ $var == "something" ]; then

 with:

   if [ "$var" = "something" ]; then

 For the specific case in setup-apkrepos, I think that case ... in would 
 be better:

 case "$setup_method" in
   random)
     get_random_method;;
   fastest)
     get_fastest_mirror;;
   mirror_list)
     prompt_mirror_list;;
   custom_mirror)
     prompt_clear_repositories;;
 esac

 2) I dont like the 2 y/n questions at setup-alpine end.
 Setup internet apk repositories? [y/N]?
 Change timezone (default is UTC)? [y/N]?

 I think we don't need those questions. Better would be

 How would you like to set up the apk repostories?
 1) Automatically...
 ...
 5) do not setup apk repositories at all.
 Please select how to setup APK repositories [5]:

 Then we have 1 less question to ask user.

 Same goes for timezone.

 If you are ok with it I'll change the above.

 I will have a look at the setup-disk script and then make an 
 alpine-conf 2.6 release with the new stuff.

 Thanks!

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Jeff Bilyk <[email-masked]>
Date: Mon, 28 Feb 2011 12:10:34 -0500

On Mon, Feb 28, 2011 at 10:21 AM, Natanael Copa <[email-masked]> wrote:
> For the specific case in setup-apkrepos, I think that case ... in would be
> better:
>
> case "$setup_method" in
>  random)
>    get_random_method;;
>  fastest)
>    get_fastest_mirror;;
>  mirror_list)
>    prompt_mirror_list;;
>  custom_mirror)
I'm fine with those changes, change away :).
>
> I will have a look at the setup-disk script and then make an alpine-conf 2.6
> release with the new stuff.
>
> Thanks!
>
>
> ---

-- 
Jeff

---