Subject: [alpine-devel] [PATCH] main/freeswitch-sounds-en-us-callie-8000: fix permissions

From: Jeff Bilyk <[email-masked]>
Date: Sat, 4 Mar 2006 12:58:29 +0000

fixes #446
---
 main/freeswitch-sounds-en-us-callie-8000/APKBUILD  |    4 ++--
 ...reeswitch-sounds-en-us-callie-8000.post-install |    5 +++++
 2 files changed, 7 insertions(+), 2 deletions(-)
 create mode 100755 main/freeswitch-sounds-en-us-callie-8000/freeswitch-sounds-en-us-callie-8000.post-install

diff --git a/main/freeswitch-sounds-en-us-callie-8000/APKBUILD b/main/freeswitch-sounds-en-us-callie-8000/APKBUILD
index 5677355..81aa49d 100644
--- a/main/freeswitch-sounds-en-us-callie-8000/APKBUILD
+++ b/main/freeswitch-sounds-en-us-callie-8000/APKBUILD
@@ -2,13 +2,13 @@
 # Maintainer: 
 pkgname=freeswitch-sounds-en-us-callie-8000
 pkgver=1.0.13
-pkgrel=0
+pkgrel=1
 pkgdesc="Sounds for freeswitch English"
 url="http://files.freeswitch.org/"
 license="unknown"
 depends=
 makedepends=
-install=
+install="$pkgname.post-install"
 subpackages=
 source="http://files.freeswitch.org/freeswitch-sounds-en-us-callie-8000-$pkgver.tar.gz"
 
diff --git a/main/freeswitch-sounds-en-us-callie-8000/freeswitch-sounds-en-us-callie-8000.post-install b/main/freeswitch-sounds-en-us-callie-8000/freeswitch-sounds-en-us-callie-8000.post-install
new file mode 100755
index 0000000..14cc2c5
--- /dev/null
+++ b/main/freeswitch-sounds-en-us-callie-8000/freeswitch-sounds-en-us-callie-8000.post-install
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+chown -R root:root /usr/sounds/en
+
+exit 0
-- 
1.7.3.1

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Natanael Copa <[email-masked]>
Date: Wed, 20 Oct 2010 16:08:41 +0200

> +++ b/main/freeswitch-sounds-en-us-callie-8000/freeswitch-sounds-en-us-callie-8000.post-install

I think this should be fixed in APKBUILD and not with post-install

-nc

---