Subject: [alpine-devel] alpine-1.7.28.1 released

From: Natanael Copa <[email-masked]>
Date: Tue, 09 Dec 2008 16:37:42 +0100

http://wiki.alpinelinux.org/w/index.php?title=Release_Notes_for_Alpine_1.7.28.1

ipp2p and shorewall is fixed + some other stuff.

-nc

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Harry Lachanas <[email-masked]>
Date: Wed, 10 Dec 2008 10:17:51 +0200

I would enjoy some guidelines on how to start the web interface. :-)

I did an
setup-alpine-web
loaded all I could ( acf* )
mini_httpd started
but all I could see was a page
with  system health. :-(

I've setup the .htpasswd file  in some directory that I thought was 
proper but never managed to login ( after hitting the login button ).

I've also found out that as soon as I issue
a
setup-alpine-web

It starts doing all sorts of stuff reconfiguring the system setting up  
interfaces and changing the system name. :-(
Please help !!

Another issue is the number of packages that exist on the ISO images ....
and its really HUGE !!!!

I noticed that there is as script in the sdk to select a group of 
packages and create an ISO image after downloading stuff from www.
But as I played a bit with it I noticed that wasn't functional and 
started to download stuff from an old version.!

I  most likely  would like to avoid having  gcc as well as other goodies 
available on a production firewall-router. :-)

Cheers and Thanks.
Harry.

---

---

From: Natanael Copa <[email-masked]>
Date: Wed, 10 Dec 2008 13:27:44 +0100

> I would enjoy some guidelines on how to start the web interface. :-)

this script is something i started with, but not really finished. The
idea is a web based alpine-setup for headless boxes.

Try setup-webconf.

> but all I could see was a page

You need to login. Default user is 'alpine' and password 'test123'.

> proper but never managed to login ( after hitting the login button ).

users/roles are found in /etc/acf/passwd

> interfaces and changing the system name. :-(

and starts dhcp and stuff so you can plug a laptop to a headless box and
get a welcome wizard. Unfortunally the wizard is not here.

setup-webconf

> Another issue is the number of packages that exist on the ISO images ....

you don need to install all of them

> started to download stuff from an old version.!

yeah. i am moving away from using gentoo to build the stuff.

> available on a production firewall-router. :-)

gcc might be handy if you want use the iso for a distcc host in your
compile cluster ;)

Easiest would be to copy the stuff you want to USB/CF. (or to a
directory to be burned on a new cd). copy the packages you want (or
remove those you dont want) and:

md5sum *.apk | gzip -c > INDEX.md5.gz

> Harry.

thanks!

-nc

---

---

From: Harry Lachanas <[email-masked]>
Date: Wed, 10 Dec 2008 14:30:28 +0200

Any Vlan support included ???

if yes which package(s) I should apk_add ???

Cheers,
Harry.

---

---

From: Nathan Angelacos <[email-masked]>
Date: Wed, 10 Dec 2008 09:24:44 -0500

> Any Vlan support included ???

absolutely
> if yes which package(s) I should apk_add ???

vconfig is in busybox these days; or you can apk_add vconfig
As far as setting up the vlans, I tend to use the 
/etc/network/interfaces file for all configuration of interfaces 
(bonding,vlans,bridges, etc)

Example vlan config:

/etc/modules
  8021q

/etc/network/interfaces

-- the physical interface
auto eth0
iface eth0 inet manual
    up ifup eth0.300
    up ifup eth0.200
    down ifdown eth0 300
    down ifdown eth0 200

-- vlan 200
iface eth0.200 inet dhcp
    pre-up vconfig add eth0 200
    hostname alpine-vlan-200
    post-down vconfig rem $IFACE

-- vlan 300
iface eth0.300 inet static
   pre-up vconfig add eth0 300
   address 192.168.1.1
   netmask 255.255.255.0
   post-down vconfig rem $IFACE

That lets you manage the vlans with an ifup/ifdown:

ifup eth0 <- brings up all vlans
ifdown eth0.200 <- takes down 200, but leaves up the 300 vlan iface

HTH

---