Subject: Re: [alpine-devel] [PATCH] testing/device-mapper: new aport

From: Natanael Copa <[email-masked]>
Date: Thu, 26 Feb 2009 15:38:28 +0100

(i took the liberty to CC alpine-devel for the record)

On Thu, 2009-02-26 at 15:32 +0100, Leonardo Arena wrote:
> i've checked, it's included in lvm2, so you may discard the patch.
> i've added makedepends=lvm2-dev to multipath-tools
> sorry for double work :(

No, i think this was good. I wondered this when i was working on lvm2.

Can you verify that your packages needs is libdevmapper?

for multipath-tools:

scanelf -Rn pkg

will probably show libdevmapper. Then you would technically need to add
lvm2 as a depends as well, which we probably dont want (too much stuff
there it does not need)

I think we might want split out libdevmapper to a separate package.

Thanks!

> leo
> 
> On Thu, Feb 26, 2009 at 2:16 PM, Natanael Copa
> <[email-masked]> wrote:
>         On Thu, 2009-02-26 at 13:47 +0100, Leonardo Arena wrote:
>         > i need multipath-tools for my iSCSI storage. Need that as
>         dependency
>         > as well as libaio (currently working on).
>         
>         
>         wow cool...
>         I'll commit as is (need to clean up so i can pull cleanly
>         first).
>         
>         testing is a good place. We need to check so it does not
>         clloide with
>         lvm2.
>         
>         Thanks!
>         
>         -nc
>         
>         
>         > Thanks!
>         >
>         > On Thu, Feb 26, 2009 at 11:00 AM, Natanael Copa
>         > <[email-masked]> wrote:
>         >         On Thu, 2009-02-26 at 10:41 +0100, Leonardo Arena
>         wrote:
>         >         > please review attached patch
>         >
>         >         thanks!
>         >
>         >         Is this needed? Who/what needs it?
>         >
>         >         Doesnt lvm2 provide same functionallity itself?
>         >
>         >         (iirc arch linux build device-mapper from lvm2
>         sources so i
>         >         thought it
>         >         was not needed with the separate device-mapper pkg)
>         >
>         >         > leo
>         >
>         >
>         
>         
> 

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Leonardo Arena <[email-masked]>
Date: Thu, 26 Feb 2009 15:58:50 +0100

> Can you verify that your packages needs is libdevmapper?
Yes it does
"devmapper.c:11:26: error: libdevmapper.h: No such file or directory"
thanks
leo

---

From: Natanael Copa <[email-masked]>
Date: Thu, 26 Feb 2009 16:22:57 +0100

On Thu, 2009-02-26 at 15:58 +0100, Leonardo Arena wrote:
> On Thu, Feb 26, 2009 at 3:38 PM, Natanael Copa

I was thinking the runtime dependency. if it was dynamically linked to
libdevmapper. I'm almost sure it is (unless it is explicitly linked
statically which i cant remember i have ever seen until now)

I'll take a closer look at this after 1.8.1 release.

Thanks!

-nc

---

---

From: Leonardo Arena <[email-masked]>
Date: Thu, 26 Feb 2009 16:37:12 +0100

> statically which i cant remember i have ever seen until now)

Sorry, i've not yet built multipath-tools, so i could not verify with
scanelf.
It needs libaio, that is not yet ready...
thanks