Subject: [alpine-devel] Brainstorming for 2.1

From: Natanael Copa <[email-masked]>
Date: Thu, 12 Aug 2010 14:56:44 +0200

Hi,

So we are getting close the 2.0 release. I think I'll just shoot the
engineer and just ship the product eitehr tomorrow or monday. Whats not
solved yet will be rescheduled to 2.1 release. Stuff in testing repo
will also be deleted from v2.0 tree after the 2.0.0 tag and branch. This
stuff is still candidates for 2.1.x.

We can also start think what stuff we want in there for 2.1 release.
Some stuff from the top of my head:

* gcc-4.5.x
* linux 2.6.35.x kernels
* apk-tools' install_if/virtual package feature
* 64 bit version

Possilby also:
* unattended installer (based on irc discussion with mattx86)

There are some infrastruc ideas:
* web (user) forums (fluxbb?)
* alpine-user mailing list
* blog.alpinelinux.org (running wordpress?)

If you have other ideas, please feel free to post them here. We can also
collect the ideas (and clean up) the http://alpinelinux.org/wiki/Ideas
page or set up a "BrainStorming2.1" page or similar.

-nc

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Nathan Angelacos <[email-masked]>
Date: Thu, 12 Aug 2010 10:34:27 -0700

> * apk-tools' install_if/virtual package feature

Really want:
* Ikeda (Fabled's IPSec IKE daemon)

Would be cool:
* MIPS port (Alpine on Netgear/LinkSys/Buffalo routers)

---

---

From: qnx4ever <[email-masked]>
Date: Thu, 12 Aug 2010 23:14:26 +0400

Routers version would be great indeed, while supporting different hw
platforms with its individual issues could lead Alpine to become OpenWrt ;)

For those of us joining only recently, forum could be a great thing.

On 12/08/2010 9:34 PM, "Nathan Angelacos" <[email-masked]> wrote:

On 08/12/10 05:56, Natanael Copa wrote:

> We can also start think what stuff we want in there for 2...
Really want:

Would be cool:

---
Unsubscribe:  [email-masked]<[email-masked]>
Help:         alpine-devel+help...

---

From: Cameron Banta <[email-masked]>
Date: Thu, 12 Aug 2010 14:21:14 -0500

> * web (user) forums (fluxbb?)
Doesn't redmine already have forums?

-Cameron

---

---

From: Natanael Copa <[email-masked]>
Date: Fri, 13 Aug 2010 08:09:35 +0200

> Doesn't redmine already have forums?

Oh, yes it does. And it has wiki too - but still we use mediawiki for wiki.

Is redmines forums good enough? I suppose Its just to enable it and
see what happens...

-- 
Natanael Copa

---