Subject: [alpine-devel] [PATCH] main/iscsitarget: add iscsitarget-grsec as dependency

From: Jeff Bilyk <[email-masked]>
Date: Fri, 8 Oct 2010 16:06:38 +0000

Fixes #442
---
 main/iscsitarget/APKBUILD |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

diff --git a/main/iscsitarget/APKBUILD b/main/iscsitarget/APKBUILD
index a53e628..ea7c129 100644
--- a/main/iscsitarget/APKBUILD
+++ b/main/iscsitarget/APKBUILD
@@ -6,7 +6,7 @@ pkgrel=2
 pkgdesc="Open Source iSCSI target with professional features - userspace utils"
 url="http://iscsitarget.sourceforge.net/"
 license="GPL-2"
-depends=
+depends="iscsitarget-grsec"
 makedepends="openssl-dev"
 subpackages="$pkgname-doc"
 source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
-- 
1.7.2.1

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Natanael Copa <[email-masked]>
Date: Tue, 12 Oct 2010 17:04:57 +0200

On Fri, 2010-10-08 at 16:06 +0000, Jeff Bilyk wrote:

sorry for long delay on the answer.

>  source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz

As explained, this will create problems if user install linux-vserver
kernel or any other kernel flavor and we create a
iscsitarget-otherflavor.

We do have a plan how to solve it. I finally got the ticket created for
that:
http://redmine.alpinelinux.org/issues/443

Now its just find time to implement it.

Meanwhile, I updated the wiki doc for the next person:
http://alpinelinux.org/w/index.php?title=ISCSI_Target_and_Initiator_Configuration&action=historysubmit&diff=4494&oldid=3829

Thanks!

-nc

---