Subject: [alpine-devel] [PATCH] testing/zabbix: added zabbix-agent subpackage

From: Duane Hughes <[email-masked]>
Date: Fri, 3 Dec 2010 13:49:23 +0000

created zabbix-agent subpackage, added default config, bumped pkgrel
ref #251
---
 testing/zabbix/APKBUILD                 |   24 +++-
 testing/zabbix/zabbix-agent.pre-install |    5 +
 testing/zabbix/zabbix_agentd.conf       |  230 +++++++++++++++++++++++++++++++
 3 files changed, 256 insertions(+), 3 deletions(-)
 create mode 100644 testing/zabbix/zabbix-agent.pre-install
 create mode 100644 testing/zabbix/zabbix_agentd.conf

diff --git a/testing/zabbix/APKBUILD b/testing/zabbix/APKBUILD
index 9c60123..2c28099 100644
--- a/testing/zabbix/APKBUILD
+++ b/testing/zabbix/APKBUILD
@@ -2,7 +2,7 @@
 # Maintainer: Natanael Copa <[email-masked]>
 pkgname=zabbix
 pkgver=1.8.3
-pkgrel=0
+pkgrel=1
 pkgdesc="Enterprise-class open source distributed monitoring"
 url="www.zabbix.com"
 license="GPL"
@@ -11,11 +11,12 @@ makedepends="postgresql-dev curl-dev libiconv-dev net-snmp-dev"
 install="$pkgname.pre-install"
 pkgusers="zabbix"
 pkggroups="zabbix"
-subpackages="$pkgname-doc"
+subpackages="$pkgname-doc $pkgname-agent"
 source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
 	zabbix_server.conf
 	zabbix_trapper.conf
 	zabbix_proxy.conf
+	zabbix_agentd.conf
 	zabbix-dn_skipname.patch
 	zabbix-getloadavg.patch
 	zabbix-server.initd
@@ -71,17 +72,34 @@ package() {
 	install -D -m0755 "$srcdir"/zabbix-$pkgver/create/schema/postgresql.sql "$pkgdir"/usr/share/zabbix/dbms/create/postgresql.sql
 	cp -r "$srcdir"/zabbix-$pkgver/frontends/php/* "$_wwwdir"
 	
-	for i in server proxy agentd; do
+	for i in server proxy; do
 		install -D -m0755 "$srcdir"/zabbix-$i.initd \
 			"$pkgdir"/etc/init.d/zabbix-$i || return 1
 	done
   
 }
 
+agent() {
+	pkgdesc="Zabbix Network Monitoring Agent"
+	depends=
+	install="$subpkgname.pre-install"
+	
+        install -d -m0750 -o zabbix -g zabbix \
+                "$subpkgdir"/var/run/zabbix "$subpkgdir"/var/log/zabbix
+                        
+	install -d "$subpkgdir"/etc/zabbix
+	install -D -m0644 "$srcdir"/zabbix_agentd.conf "$subpkgdir"/etc/zabbix/zabbix_agentd.conf
+	install -D -m0755 "$srcdir"/zabbix-agentd.initd "$subpkgdir"/etc/init.d/zabbix-agentd
+
+	mkdir -p "$subpkgdir"/usr/sbin
+	mv -f "$pkgdir"/usr/sbin/zabbix_agentd "$subpkgdir"/usr/sbin/
+}
+
 md5sums="575c31880d73f6fe41e730874ebfc633  zabbix-1.8.3.tar.gz
 26b0401a83bdb1dce29338e5b2786620  zabbix_server.conf
 9832a81e134c8e2c11e2a06b7adbf88f  zabbix_trapper.conf
 0310b92afb3f35c1075fff53db737212  zabbix_proxy.conf
+0fe55827fe49424a9f59fd43cc905ae1  zabbix_agentd.conf
 d13166483792401be2d25b37b0170b82  zabbix-dn_skipname.patch
 8d1d2e53479173aac0df0c38a4d6afda  zabbix-getloadavg.patch
 e42394e798ab98a8ff4babe68e04633a  zabbix-server.initd
diff --git a/testing/zabbix/zabbix-agent.pre-install b/testing/zabbix/zabbix-agent.pre-install
new file mode 100644
index 0000000..8a9e519
--- /dev/null
+++ b/testing/zabbix/zabbix-agent.pre-install
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+addgroup zabbix 2>/dev/null
+adduser -S -H -h /dev/null -s /bin/false -D -G zabbix zabbix 2>/dev/null
+exit 0
diff --git a/testing/zabbix/zabbix_agentd.conf b/testing/zabbix/zabbix_agentd.conf
new file mode 100644
index 0000000..8b56407
--- /dev/null
+++ b/testing/zabbix/zabbix_agentd.conf
@@ -0,0 +1,230 @@
+# This is a config file for Zabbix Agent (Unix)
+# To get more information about Zabbix, visit http://www.zabbix.com
+
+############ GENERAL PARAMETERS #################
+
+### Option: PidFile
+#	Name of PID file.
+#
+# Mandatory: no
+# Default:
+PidFile=/var/run/zabbix/zabbix_agentd.pid
+
+### Option: LogFile
+#	Name of log file.
+#	If not set, syslog is used.
+#
+# Mandatory: no
+# Default:
+# LogFile=
+
+LogFile=/var/log/zabbix/zabbix_agentd.log
+
+### Option: LogFileSize
+#	Maximum size of log file in MB.
+#	0 - disable automatic log rotation.
+#
+# Mandatory: no
+# Range: 0-1024
+# Default:
+# LogFileSize=1
+
+### Option: DebugLevel
+#	Specifies debug level
+#	0 - no debug
+#	1 - critical information
+#	2 - error information
+#	3 - warnings
+#	4 - for debugging (produces lots of information)
+#
+# Mandatory: no
+# Range: 0-4
+# Default:
+# DebugLevel=3
+
+### Option: SourceIP
+#	Source IP address for outgoing connections.
+#
+# Mandatory: no
+# Default:
+# SourceIP=
+
+### Option: EnableRemoteCommands
+#	Whether remote commands from Zabbix server are allowed.
+#	0 - not allowed
+#	1 - allowed
+#
+# Mandatory: no
+# Default:
+# EnableRemoteCommands=0
+
+### Option: LogRemoteCommands
+#	Enable logging of executed shell commands as warnings
+#	0 - disabled
+#	1 - enabled
+#
+# Mandatory: no
+# Default:
+# LogRemoteCommands=0
+
+##### Passive checks related
+
+### Option: Server
+#	List of comma delimited IP addresses (or hostnames) of Zabbix servers.
+#	No spaces allowed. First entry is used for receiving list of and sending active checks.
+#	Note that hostnames must resolve hostname->IP address and IP address->hostname.
+#	If IPv6 support is enabled then '127.0.0.1', '::127.0.0.1', '::ffff:127.0.0.1' are treated equally.
+#
+# Mandatory: yes
+# Default:
+# Server=
+
+Server=
+
+### Option: Hostname
+#	Unique, case sensitive hostname.
+#	Required for active checks and must match hostname as configured on the server.
+#
+# Default:
+# Hostname=system.uname
+
+Hostname=
+
+### Option: ListenPort
+#	Agent will listen on this port for connections from the server.
+#
+# Mandatory: no
+# Range: 1024-32767
+# Default:
+# ListenPort=10050
+
+### Option: ListenIP
+#	List of comma delimited IP addresses that the agent should listen on.
+#
+# Mandatory: no
+# Default:
+# ListenIP=0.0.0.0
+
+# ListenIP=127.0.0.1
+
+### Option: DisablePassive
+#	Disable passive checks. The agent will not listen on any TCP port.
+#	Only active checks will be processed.
+#	0 - do not disable
+#	1 - disable
+#
+# Mandatory: no
+# Default:
+# DisablePassive=0
+
+##### Active checks related
+
+### Option: DisableActive
+#	Disable active checks. The agent will work in passive mode listening for server.
+#
+# Mandatory: no
+# Default:
+# DisableActive=0
+
+# DisableActive=1
+
+### Option: ServerPort
+#	Server port for retrieving list of and  sending active checks.
+#
+# Mandatory: no
+# Default:
+# ServerPort=10051
+
+### Option: RefreshActiveChecks
+#	How often list of active checks is refreshed, in seconds.
+#
+# Mandatory: no
+# Range: 60-3600
+# Default:
+# RefreshActiveChecks=120
+
+### Option: BufferSend
+#	Do not keep data longer than N seconds in buffer.
+#
+# Mandatory: no
+# Range: 1-3600
+# Default:
+# BufferSend=5
+
+### Option: BufferSize
+#	Maximum number of values in a memory buffer. The agent will send
+#	all collected data to Zabbix Server or Proxy if the buffer is full.
+#
+# Mandatory: no
+# Range: 2-65535
+# Default:
+# BufferSize=100
+
+### Option: MaxLinesPerSecond
+#	Maximum number of new lines the agent will send per second to Zabbix Server
+#	or Proxy processing 'log' and 'logrt' active checks.
+#	The provided value will be overridden by the parameter 'maxlines',
+#	provided in 'log' or 'logrt' item keys.
+#
+# Mandatory: no
+# Range: 1-1000
+# Default:
+# MaxLinesPerSecond=100
+
+
+############ ADVANCED PARAMETERS #################
+
+### Option: StartAgents
+#	Number of pre-forked instances of zabbix_agentd that process passive checks.
+#
+# Mandatory: no
+# Range: 1-16
+# Default:
+# StartAgents=3
+
+### Option: Timeout
+#	Spend no more than Timeout seconds on processing
+#
+# Mandatory: no
+# Range: 1-30
+# Default:
+# Timeout=3
+
+### Option: Include
+#	You may include individual files or all files in a directory in the configuration file.
+#
+# Mandatory: no
+# Default:
+# Include=
+
+# Include=/etc/zabbix/zabbix_agent.userparams.conf
+# Include=/etc/zabbix/zabbix_agentd/
+
+
+####### USER-DEFINED MONITORED PARAMETERS #######
+
+### Option: UnsafeUserParameters
+#	Allow all characters to be passed in arguments to user-defined parameters.
+#	0 - do not allow
+#	1 - allow
+#
+# Mandatory: no
+# Range: 0-1
+# Default:
+# UnsafeUserParameters=0
+
+### Option: UserParameter
+#	User-defined parameter to monitor. There can be several user-defined parameters.
+#	Format: UserParameter=<key>,<shell command>
+#	Note that shell command must not return empty string or EOL only.
+#	Example: UserParameter=system.test,who|wc -l
+#UserParameter=system.test,who|wc -l
+### Set of parameters for monitoring MySQL server (v3.23.42 and later)
+### Change -u<username> and add -p<password> if required
+#UserParameter=mysql.ping,mysqladmin -uroot ping|grep alive|wc -l
+#UserParameter=mysql.uptime,mysqladmin -uroot status|cut -f2 -d":"|cut -f1 -d"T"
+#UserParameter=mysql.threads,mysqladmin -uroot status|cut -f3 -d":"|cut -f1 -d"Q"
+#UserParameter=mysql.questions,mysqladmin -uroot status|cut -f4 -d":"|cut -f1 -d"S"
+#UserParameter=mysql.slowqueries,mysqladmin -uroot status|cut -f5 -d":"|cut -f1 -d"O"
+#UserParameter=mysql.qps,mysqladmin -uroot status|cut -f9 -d":"
+#UserParameter=mysql.version,mysql -V
-- 
1.7.3.2

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Natanael Copa <[email-masked]>
Date: Mon, 06 Dec 2010 16:49:12 +0100

> created zabbix-agent subpackage, added default config, bumped pkgrel

applied.

thanks!

-nc

---