Subject: [alpine-devel] [PATCH] abuild: trivial update to new saveas-*:// support

From: Matt Smith <[email-masked]>
Date: Fri, 31 Dec 2010 14:46:56 -0600

Removed the asterisk from the beginning of the https check, and moved the
saveas- check above.
---
 abuild.in |   10 +++++-----
 1 files changed, 5 insertions(+), 5 deletions(-)

diff --git a/abuild.in b/abuild.in
index ec40612..bbfbf98 100755
--- a/abuild.in
+++ b/abuild.in
@@ -177,17 +177,17 @@ uri_fetch() {
 	[ -n "$quiet" ] && opts="-q"
 	[ -f "$SRCDEST/$d" ] && return 0
 
-	# we need GNU wget for this
-	case "$uri" in
-		*https://*) opts="--no-check-certificate";;
-	esac
-
 	# fix saveas-*://* URIs
 	case "$uri" in
 		# remove 'saveas-' from beginning and
 		# '/filename' from end of URI
 		saveas-*://*) uri="${uri:7:$(expr ${#uri} - 7 - ${#d} - 1)}";;
 	esac
+
+	# we need GNU wget for this
+	case "$uri" in
+		https://*) opts="--no-check-certificate";;
+	esac
 	
 	mkdir -p "$SRCDEST"
 	if [ -f "$SRCDEST/$d.part" ]; then
-- 
1.7.3.3

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Natanael Copa <[email-masked]>
Date: Mon, 3 Jan 2011 14:45:07 +0100

On Fri, 31 Dec 2010 14:46:56 -0600
Matt Smith <[email-masked]> wrote:

> Removed the asterisk from the beginning of the https check, and moved
> the saveas- check above.
> ---

Applied. Thanks!

-nc

---