Subject: [alpine-devel] [PATCH] sems: create var/run/sems dir on install

From: Nathan Angelacos <[email-masked]>
Date: Mon, 2 May 2011 12:43:26 +0000

---
 testing/sems/APKBUILD |    1 +
 1 files changed, 1 insertions(+), 0 deletions(-)

diff --git a/testing/sems/APKBUILD b/testing/sems/APKBUILD
index 49a61ad..d9cb870 100644
--- a/testing/sems/APKBUILD
+++ b/testing/sems/APKBUILD
@@ -76,6 +76,7 @@ package() {
 	rm -f "$pkgdir"/etc/sems/etc/conf_auth.conf
 
 	install -o sems -g sems -d "$pkgdir"/var/spool/voicebox
+	install -d -o sems  "$pkgdir"/var/run/sems
 }
 
 _mv_sub() {
-- 
1.7.4.4

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Nathan Angelacos <[email-masked]>
Date: Sun, 01 May 2011 21:52:48 -0700

After this patch, sems 1.4.0  (and related subpackages) are ready for 
main IMHO.

---

---

From: Natanael Copa <[email-masked]>
Date: Mon, 2 May 2011 08:21:26 +0200

On Sun, 01 May 2011 21:52:48 -0700

> After this patch, sems 1.4.0  (and related subpackages) are ready for 

Its a little late in the game, but I suppose there are not too many who
uses it in production from v2.2 (if any). I think we do an exception
and add it to main for includsion in v2.2. Its kinda nice to have a
recent version since we will maintain it for some time.

Thanks!

-nc

---

---

From: Nathan Angelacos <[email-masked]>
Date: Mon, 02 May 2011 07:02:56 -0700

On 05/01/2011 11:21 PM, Natanael Copa wrote:
> Nathan Angelacos<[email-masked]>  wrote:
>

No problem on not adding to v2.2 if you think its too late v2.3 is ok - 
but it should at least be in edge main, and not edge testing.

---

---

From: Natanael Copa <[email-masked]>
Date: Mon, 2 May 2011 08:19:15 +0200

On Mon,  2 May 2011 12:43:26 +0000

> +	install -d -o sems  "$pkgdir"/var/run/sems

Is this really needed? I think we create the dir from init.d script in
case /var/run happens to be a tmpfs mount (yeah, we probably need a
major cleanup in lots of init.d scripts to get that actually working)

Secondly, always bump pkgrel when contents of package changes.
Otherwise it will not be rebuilt. And even if it would, people who has
it installed will not have it upgraded unless pkgver/pkgrel changes.

I applied it anyways and bumped pkgrel.

Thanks!

-nc

---