Subject: [alpine-devel] New package idea

From: Ted Trask <[email-masked]>
Date: Thu, 6 Oct 2011 13:12:43 -0700 (PDT)

I would like to create some new packages for automatic provisioning of SIP devices. The packages would contain device firmware and basic config files. So, you would have acf-provisioning-polycom, acf-provisioning-snom, ...

The idea is that the device-specific packages would contain the static files for the phones and the dynamic configuration of specific phones would be handled by the acf-provisioning app. Alternatively, you could use the static files without the acf-provisioning app, and manually edit config files for each phone.

I would like some help creating the first package - acf-provisioning-polycom-3.3.1F
Here's what it should contain:
Put all of the .ld files, the .wav files, and the SoundPointIPLocalization directory from http://downloads.polycom.com/voice/voip/uc/UC_Software_3_3_1F_release_sig_split.zip into /var/www/provisioning/htdocs
Put all of the .ld files except "bootrom.ld" from http://downloads.polycom.com/voice/voip/sp_ss_bootrom/spip_ssip_BootROM_4_3_0_release_sig.zip into /var/www/provisioning/htdocs
Put the attached 000000000000.cfg file into /var/www/provisioning/htdocs

If someone can help me create the APKBUILD file for this package, I should be able to handle the others as they come up.

Thanks.

Ted

---

From: Carlo Landmeter <[email-masked]>
Date: Fri, 7 Oct 2011 12:44:46 +0200

On Thu, Oct 6, 2011 at 10:12 PM, Ted Trask <[email-masked]> wrote:
> I would like to create some new packages for automatic provisioning of SIP
> devices. The packages would contain device firmware and basic config files.
> So, you would have acf-provisioning-polycom, acf-provisioning-snom, ...
> The idea is that the device-specific packages would contain the static files
> for the phones and the dynamic configuration of specific phones would be
> handled by the acf-provisioning app. Alternatively, you could use the static
> files without the acf-provisioning app, and manually edit config files for
> each phone.
> Put all of the .ld files, the .wav files, and the SoundPointIPLocalization
> directory from
> http://downloads.polycom.com/voice/voip/uc/UC_Software_3_3_1F_release_sig_split.zip
> into /var/www/provisioning/htdocs
> Put all of the .ld files except "bootrom.ld" from
> http://downloads.polycom.com/voice/voip/sp_ss_bootrom/spip_ssip_BootROM_4_3_0_release_sig.zip

Are we allowed to redistribute these files, or do you want to add them
later manually?

Carlo

> into /var/www/provisioning/htdocs
> If someone can help me create the APKBUILD file for this package, I should
> be able to handle the others as they come up.
> Thanks.
> Ted
>
>

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Ted Trask <[email-masked]>
Date: Sat, 8 Oct 2011 18:43:31 -0700 (PDT)

I'll put it this way, I haven't see anything that says we can't. The bootloader / firmware is quite useless unless you've purchased a device.

Ted

________________________________
From: Carlo Landmeter <[email-masked]>
To: Ted Trask <[email-masked]>
Cc: Alpine Developers <[email-masked]>
Sent: Friday, October 7, 2011 6:44 AM
Subject: Re: [alpine-devel] New package idea

Carlo

---

From: Jeff Bilyk <[email-masked]>
Date: Sat, 08 Oct 2011 23:35:07 -0400

On 10/8/2011 9:43 PM, Ted Trask wrote:
> I'll put it this way, I haven't see anything that says we can't. The 
> bootloader / firmware is quite useless unless you've purchased a device.
That's about what I see as well. 
http://supportdocs.polycom.com/PolycomService/support/global/documents/support/setup_maintenance/products/voice/UC_Software_Admin_Guide_v4_0_0.pdf 
is the closest I found to something containing a yes/no to distributing 
it (and since I'm terrible at interpretting legalese, I just include it 
here). See that as long as we have that copyright notice in the package 
somewhere, we'd be ok.

Permission is hereby granted, free of charge, to any person obtaining a 
copy of this software and associated
documentation files (the “Software”), to deal in the Software without 
restriction, including without limitation the rights
to use, copy, modify, merge, publish, distribute, sublicense, and/or 
sell copies of the Software, and to permit persons
to whom the Software is furnished to do so, subject to the following 
conditions:
The above copyright notice and this permission notice shall be included 
in all copies or substantial portions of the
Software.
THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND, EXPRESS 
OR IMPLIED,
INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS 
FOR A PARTICULAR
PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT 
HOLDERS BE
LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION 
OF CONTRACT, TORT
OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR 
THE USE OR
OTHER DEALINGS IN THE SOFTWARE

Jeff

>
> Ted
>
> ------------------------------------------------------------------------
> *From:* Carlo Landmeter <[email-masked]>
> *To:* Ted Trask <[email-masked]>
> *Cc:* Alpine Developers <[email-masked]>
> *Sent:* Friday, October 7, 2011 6:44 AM
> *Subject:* Re: [alpine-devel] New package idea
>
> On Thu, Oct 6, 2011 at 10:12 PM, Ted Trask <[email-masked] 
> <mailto:[email-masked]>> wrote:

---

---

From: Ted Trask <[email-masked]>
Date: Sun, 9 Oct 2011 07:59:14 -0400

Thanks Jeff. I hadn't seen that. Interestingly, the copyright and permission notice you cite are not included in ReadMe.txt or sip.ver, the two likely files in the zip. So, they don't include them in their own distribution. And the bootrom zip file contains only binary files. Assuming the notice is embedded in the binary files, I doubt we need to do anything (besides what I already requested). If no one is able to create an APKBUILD for me, I'll take a stab tomorrow.

Ted

On Oct 8, 2011, at 11:35 PM, Jeff Bilyk <[email-masked]> wrote:

> That's about what I see as well. http://supportdocs.polycom.com/PolycomService/support/global/documents/support/setup_maintenance/products/voice/UC_Software_Admin_Guide_v4_0_0.pdf is the closest I found to something containing a yes/no to distributing it (and since I'm terrible at interpretting legalese, I just include it here). See that as long as we have that copyright notice in the package somewhere, we'd be ok.
> 
> Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated
> documentation files (the “Software”), to deal in the Software without restriction, including without limitation the rights
> to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons
> to whom the Software is furnished to do so, subject to the following conditions:
> The above copyright notice and this permission notice shall be included in all copies or substantial portions of the
> Software.
> THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED,
> INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR
> PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE
> LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT
> OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
>> On Thu, Oct 6, 2011 at 10:12 PM, Ted Trask <[email-masked] <mailto:[email-masked]>> wrote:

---