Subject: [alpine-devel] [PATCH] testing/ocaml: new aport

From: Borys Zhukov <[email-masked]>
Date: Fri, 13 Apr 2012 23:59:16 +0000

---
 testing/ocaml/APKBUILD |    5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

diff --git a/testing/ocaml/APKBUILD b/testing/ocaml/APKBUILD
index 42c837f..922ec14 100644
--- a/testing/ocaml/APKBUILD
+++ b/testing/ocaml/APKBUILD
@@ -6,7 +6,7 @@ pkgrel=0
 pkgdesc="Main implementation of the Caml programming language"
 url="http://caml.inria.fr"
 arch="all"
-license="QPL/GPLv2"
+license="QPL-1.0/LGPL-2"
 depends="gdbm"
 depends_dev="ncurses"
 makedepends="$depends_dev"
@@ -28,7 +28,8 @@ prepare() {
 
 build() {
 	cd "$_builddir"
-	./configure -bindir /usr/bin \
+	./configure -cc "gcc -fPIC" \
+		-bindir /usr/bin \
 		-libdir /usr/lib/ocaml \
 		-mandir /usr/share/man \
 		-no-tk \
-- 
1.7.9.6

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Natanael Copa <[email-masked]>
Date: Sat, 14 Apr 2012 02:58:18 +0200

On Fri, 13 Apr 2012 23:59:16 +0000

>  1 file changed, 3 insertions(+), 2 deletions(-)

as said in IRC, I pushed a fixed version of the original patch you sent.

Thanks!

-nc

---