Subject: [alpine-devel] Re: [acf] Windows 7 on Xen Using Alpine Linux

From: Ted Trask <[email-masked]>
Date: Wed, 17 Apr 2013 11:56:12 -0700 (PDT)

I think you wanted to send this to the alpine-devel mailing list. I have copied that list too so that they can respond.

Ted

________________________________
 From: Richard Johnson <[email-masked]>
To: [email-masked] 
Sent: Wednesday, April 17, 2013 10:59 AM
Subject: Re: [acf] Windows 7 on Xen Using Alpine Linux

Does anyone have any clue on where I can the solution to this question?

On 04/14/2013 03:38 PM, Richard Johnson wrote:

1- Is it possible to configure Windows 7 as a Xen DomU Guest on Alpine Linux? 
What are the steps to do this?
2- Is Alpine Linux appropriate for automated windows desktop virtualization, 
that is each desktop boots from network PXE and then starts up a virtualized 
windows environment using Xen.
--- Unsubscribe: [email-masked] Help: [email-masked] --- 

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Roger Pau Monné <[email-masked]>
Date: Thu, 18 Apr 2013 09:50:06 +0200

On 17/04/13 20:56, Ted Trask wrote:
> I think you wanted to send this to the alpine-devel mailing list. I have
> copied that list too so that they can respond.
> 
> Ted
> 
> ------------------------------------------------------------------------
> *From:* Richard Johnson <[email-masked]>
> *To:* [email-masked]
> *Sent:* Wednesday, April 17, 2013 10:59 AM
> *Subject:* Re: [acf] Windows 7 on Xen Using Alpine Linux
> 

Sure.

>> What are the steps to do this?

You have to create a Xen HVM (you will need to use hardware with
virtualization extensions). There's a tutorial here for example:

http://www.virtuatopia.com/index.php/Installing_and_Running_Windows_7_as_a_Xen_HVM_domainU_Guest

The config file shown on the tutorial is for xm (the old toolstack), you
should modify it a little bit to work with xl:

---
builder='hvm'
memory = 1024
vcpus=2

name = "xenwin7"
vif = [ 'type=ioemu, bridge=xenbr0' ]
acpi = 1
apic = 1
disk = [ 'file:/home/xen/xenwin7.img,hda,w',
'file:/home/xen/windows7.iso,hdc:cdrom,r' ]

#-----------------------------------------------------------------------------
# boot on floppy (a), hard disk (c) or CD-ROM (d)
# default: hard disk, cd-rom, floppy
boot="dc"
sdl=0
vnc=1
vncconsole=1
vncpasswd=''

serial='pty'
usbdevice='tablet'

---

And I would recommend using a block device as a disk (LVM) instead of a
raw file. Also, to get better IO performance you should install the PV
drivers inside the Windows VM:

http://wiki.univention.de/index.php?title=Installing-signed-GPLPV-drivers

There are also some non-GPL windows drivers from Citrix, you might also
try those if the ones above don't work well.

>> windows environment using Xen.

I guess there's nothing like this on Alpine right now, but it shouldn't
be too hard to do.

What people usually do (IMHO) is setup a big server with all the VMs
running on it, and then use lightweight machines that only run VNC to
connect to the remote server that provides the VM.

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---