Subject: [alpine-devel] Lua 5.3.0 (work1) now available

From: Jim Pryor <[email-masked]>
Date: Fri, 05 Jul 2013 22:27:37 -0400

Huh, looks like Lua 5.3 isn't years and years away like I thought it
would be. Saw this on the lua-l list:

On Fri, Jul 5, 2013, at 10:22 PM, Luiz Henrique de Figueiredo wrote:
> Lua 5.3.0 (work1) is now available for testing at
> 	http://www.lua.org/work/lua-5.3.0-work1.tar.gz
> 
> MD5     d4053ee55741eab5ecd7061326577586  -
> SHA1    ce71e80a24d1232f42d3afbdc1b034b0877f532b  -
> 
> This is a work version. An updated reference manual is included but
> all details may change in the final version.
> 
> The main change in Lua 5.3.0 is support for integers.
> 
> The complete diffs from Lua 5.2 are too extensive to show.
> 
> All feedback welcome. Thanks.
> --lhf
> 
-- 
[email-masked]

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Timo Teras <[email-masked]>
Date: Sat, 6 Jul 2013 12:50:16 +0300

On Fri, 05 Jul 2013 22:27:37 -0400

> would be. Saw this on the lua-l list:

Yeah. But the more important question is, will it be backwards
incompatible or not. I think the integer support as-is does not
introduce incompatibilities.

If it's fully backwards compatible, we can just bump lua-5.2
immediately to 5.3 when it arrives.

- Timo

---

---

From: Bartłomiej Piotrowski <[email-masked]>
Date: Sat, 06 Jul 2013 11:54:25 +0200

>> All feedback welcome. Thanks.

There we go again… It seems to introduce enough changes to ship packages
named lua5.1, lua5.2 and lua (as Lua 5.3) in future, sigh.

-- 
Bartłomiej Piotrowski
http://bpiotrowski.pl/