1

[alpine-devel] [PATCH] Corrected $pkgdesc for perl-storable

IT Offshore
Details
Message ID
<1382969509-4688-1-git-send-email-developer@it-offshore.co.uk>
Sender timestamp
1382969509
DKIM signature
missing
Download raw message
Patch: +1 -1
Additional PERL Module required by PSAD https://aur.archlinux.org/packages/psad/

$pkgdesc corrected "brings persistence to your Perl data structures containing SCALAR, ARRAY, HASH or REF objects"
---
 testing/perl-storable/APKBUILD | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/testing/perl-storable/APKBUILD b/testing/perl-storable/APKBUILD
index f07a201..9bdab70 100644
--- a/testing/perl-storable/APKBUILD
+++ b/testing/perl-storable/APKBUILD
@@ -5,7 +5,7 @@ pkgname=perl-storable
 _pkgreal=Storable
 pkgver=2.45
 pkgrel=0
-pkgdesc="unknown"
+pkgdesc="Brings persistence to your Perl data structures containing SCALAR, ARRAY, HASH or REF objects."
 url="http://search.cpan.org/dist/Storable/"
 arch="all"
 license="GPL PerlArtistic"
-- 
1.8.2.3



---
Unsubscribe:  alpine-devel+unsubscribe@lists.alpinelinux.org
Help:         alpine-devel+help@lists.alpinelinux.org
---
Timo Teras
Details
Message ID
<20131029082901.51ffa0d3@vostro>
In-Reply-To
<1382969509-4688-1-git-send-email-developer@it-offshore.co.uk> (view parent)
Sender timestamp
1383028141
DKIM signature
missing
Download raw message
On Mon, 28 Oct 2013 14:11:49 +0000
IT Offshore <tradetaxfree@gmail.com> wrote:

> Additional PERL Module required by PSAD
> https://aur.archlinux.org/packages/psad/
> 
> $pkgdesc corrected "brings persistence to your Perl data structures
> containing SCALAR, ARRAY, HASH or REF objects" ---
>  testing/perl-storable/APKBUILD | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/testing/perl-storable/APKBUILD
> b/testing/perl-storable/APKBUILD index f07a201..9bdab70 100644
> --- a/testing/perl-storable/APKBUILD
> +++ b/testing/perl-storable/APKBUILD

Now that I look into it... Is this really needed?

The README states:
| Storable is distributed as a module, but is also part of the official
| Perl core distribution, as of perl 5.8. 

I think we do not need the separate module, can just drop this as being
implicitly present. Our APKBUILD generator from CPAN detects these kind
of bundled modules automatically, and drop them from dependencies.

- Timo


---
Unsubscribe:  alpine-devel+unsubscribe@lists.alpinelinux.org
Help:         alpine-devel+help@lists.alpinelinux.org
---