3 2

[alpine-devel] [PATCH] testing/numpy: adjust build-depends

Isaac Dunham
Details
Message ID
<1410301521-20307-1-git-send-email-ibid.ag@gmail.com>
Sender timestamp
1410301521
DKIM signature
missing
Download raw message
Patch: +3 -3
* gfortran is a compile-time dependency
* openblas-dev is needed to build with openblas
---
 testing/py-numpy/APKBUILD | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/testing/py-numpy/APKBUILD b/testing/py-numpy/APKBUILD
index db7f1f8..52bf6c7 100644
--- a/testing/py-numpy/APKBUILD
+++ b/testing/py-numpy/APKBUILD
@@ -3,13 +3,13 @@
 pkgname=py-numpy
 _pkgname=numpy
 pkgver=1.8.1
-pkgrel=0
+pkgrel=1
 pkgdesc="Scientific tools for Python"
 url="http://numpy.scipy.org/"
 arch="all"
 license="BSD"
-depends="gfortran"
-depends_dev="python-dev"
+depends=""
+depends_dev="python-dev gfortran openblas-dev"
 makedepends="$depends_dev"
 install=""
 subpackages="$pkgname-dev $pkgname-doc"
-- 
2.1.0



---
Unsubscribe:  alpine-devel+unsubscribe@lists.alpinelinux.org
Help:         alpine-devel+help@lists.alpinelinux.org
---

[alpine-devel] [PATCH] testing/py-scipy: expand depends_dev

Isaac Dunham
Details
Message ID
<1410301946-20375-1-git-send-email-ibid.ag@gmail.com>
In-Reply-To
<1410301521-20307-1-git-send-email-ibid.ag@gmail.com> (view parent)
Sender timestamp
1410301946
DKIM signature
missing
Download raw message
Patch: +3 -3
assume python-dev, openblas-dev, etc. will be needed if compiling against it
---
 testing/py-scipy/APKBUILD | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/testing/py-scipy/APKBUILD b/testing/py-scipy/APKBUILD
index c9097be..b1fb0f1 100644
--- a/testing/py-scipy/APKBUILD
+++ b/testing/py-scipy/APKBUILD
@@ -3,14 +3,14 @@
 pkgname=py-scipy
 _pkgname=scipy
 pkgver=0.14.0
-pkgrel=0
+pkgrel=1
 pkgdesc="Python library for scientific computing"
 url="http://www.scipy.org"
 arch="all"
 license="BSD"
 depends="python"
-depends_dev=""
-makedepends="python-dev gfortran py-numpy-dev openblas-dev py-setuptools"
+depends_dev="python-dev gfortran py-numpy-dev openblas-dev"
+makedepends="$depends_dev py-setuptools"
 install=""
 subpackages="$pkgname-dev $pkgname-doc"
 source="http://sourceforge.net/projects/scipy/files/scipy/$pkgver/scipy-$pkgver.tar.gz"
-- 
2.1.0



---
Unsubscribe:  alpine-devel+unsubscribe@lists.alpinelinux.org
Help:         alpine-devel+help@lists.alpinelinux.org
---

Re: [alpine-devel] [PATCH] testing/py-scipy: expand depends_dev

Natanael Copa
Details
Message ID
<1410421774.6465.3@mail.alpinelinux.org>
In-Reply-To
<1410301946-20375-1-git-send-email-ibid.ag@gmail.com> (view parent)
Sender timestamp
1410407374
DKIM signature
missing
Download raw message
On Tue, Sep 9, 2014 at 8:32 PM, Isaac Dunham <ibid.ag@gmail.com> wrote:
> assume python-dev, openblas-dev, etc. will be needed if compiling 
> against it
> ---
>  testing/py-scipy/APKBUILD | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)

applied.

Thanks!

-nc



---
Unsubscribe:  alpine-devel+unsubscribe@lists.alpinelinux.org
Help:         alpine-devel+help@lists.alpinelinux.org
---

Re: [alpine-devel] [PATCH] testing/py-scipy: expand depends_dev

Isaac Dunham
Details
Message ID
<20140911143810.GA1779@newbook>
In-Reply-To
<1410421774.6465.3@mail.alpinelinux.org> (view parent)
Sender timestamp
1410446291
DKIM signature
missing
Download raw message
On Thu, Sep 11, 2014 at 05:49:34AM +0200, Natanael Copa wrote:
> On Tue, Sep 9, 2014 at 8:32 PM, Isaac Dunham <ibid.ag@gmail.com> wrote:
> >assume python-dev, openblas-dev, etc. will be needed if compiling against
> >it
> >---
> > testing/py-scipy/APKBUILD | 6 +++---
> > 1 file changed, 3 insertions(+), 3 deletions(-)
> 
> applied.
> 
> Thanks!

I see that the openblas patch (makedepend on perl) hasn't been applied yet,
though.

Thanks,
Isaac Dunham



---
Unsubscribe:  alpine-devel+unsubscribe@lists.alpinelinux.org
Help:         alpine-devel+help@lists.alpinelinux.org
---