Subject: [alpine-devel] Patch to make download flavor description visible

From: Ted Trask <[email-masked]>
Date: Fri, 23 Sep 2016 19:08:25 +0000 (UTC)

This issue has been complained about for a while, but noone has fixed it. So, here's a fix.

Apparently, I don't have access to push directly to the alpine-mksite repo. Since I don't have 'git send-email' working, I'm emailing the patch this way.

Ted
From 7222f2018a3dec6fb7edf083dde70e5b0343d6e6 Mon Sep 17 00:00:00 2001
From: Ted Trask <[email-masked]>
Date: Fri, 23 Sep 2016 18:51:49 +0000
Subject: [PATCH] downloads: make flavor description visible

---
 downloads/index.md | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/downloads/index.md b/downloads/index.md
index 1ad734c..8c09703 100644
--- a/downloads/index.md
+++ b/downloads/index.md
@@ -19,9 +19,9 @@ Released {{releases.default.datestr}}
 </tr>
 
 {{#releases.flavors}}
-<tr title="{{flavor_desc}}"><td>{{flavor_title}}</td><td></td><td></td></tr>
+<tr><td>{{flavor_title}} - {{flavor_desc}}</td><td></td><td></td></tr>
 {{#archs}}
-<tr title="{{flavor_desc}}">
+<tr>
  <td class="iso"><a href="{{iso_url}}">{{iso}}</a></td>
  <td class="size">{{size_mb}} MB</td>
  <td class="checksums">
-- 
2.4.11

---

From: Natanael Copa <[email-masked]>
Date: Mon, 26 Sep 2016 20:14:28 +0200

On Fri, 23 Sep 2016 19:08:25 +0000 (UTC)

> Apparently, I don't have access to push directly to the alpine-mksite repo. Since I don't have 'git send-email' working, I'm emailing the patch this way.

Thanks!

I pushed it and its visible at http://wwwtest.alpinelinux.org/downloads/

But I don't think it looks good. What do you think? Is it acceptable?
better than only having the flavor description in hover text?

Maybe we should re-think the downloads page layout?

-nc

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Harald Arnesen <[email-masked]>
Date: Tue, 27 Sep 2016 12:47:36 +0200

> better than only having the flavor description in hover text?

Simple and good looking.
-- 
Hilsen Harald

---

---

From: Ted Trask <[email-masked]>
Date: Mon, 26 Sep 2016 14:25:14 -0400

I didn't promise pretty. For now, I think it's better than the hover text.

Ted

> On Sep 26, 2016, at 2:14 PM, Natanael Copa <[email-masked]> wrote:
> 

---

---

From: Carlo Landmeter <[email-masked]>
Date: Wed, 28 Sep 2016 10:03:41 +0200

> Maybe we should re-think the downloads page layout?

There is not enough contrast separating the types of downloads. Would be
nice you would see that the moment you open the page.
I think also some of the descriptions could be changed as they do not
really point out the specifics of a release ie:

Vanilla: only for debugging? Alpine with a vanilla kernel without grsec
patch set. Suitable for debugging.
ARM General: its not so general as its target for hardware with uboot
bootloader. "General build for ARM architectures with uboot bootloader
support"