Subject: [alpine-devel] [PATCH] setup-apkrepos: fix detect fastest mirror - fixes #6683

From: [email-masked]
Date: Tue, 24 Jan 2017 16:39:05 +0100

From: Leonardo Arena <[email-masked]>

---
 setup-apkrepos.in | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

diff --git a/setup-apkrepos.in b/setup-apkrepos.in
index 4565852..f4d4709 100644
--- a/setup-apkrepos.in
+++ b/setup-apkrepos.in
@@ -51,7 +51,7 @@ find_fastest_mirror() {
 	for url in $MIRRORS; do
 		# warm up the dns cache
 		nslookup $(get_hostname_from_url $url) >/dev/null 2>&1
-		local time=$(time_cmd wget -q -s -T 5 \
+		local time=$(time_cmd wget -q -S -T 5 \
 			${url%/}/edge/main/$arch/APKINDEX.tar.gz)
 		if [ -n "$time" ]; then
 			echo "$time $url"
@@ -204,6 +204,8 @@ if [ -n "$JUSTADDRANDOM" ]; then
 fi
 
 if [ -n "$JUSTADDFASTEST" ]; then
+	# need GNU wget
+	apk add wget --quiet
 	show_mirror_list > /dev/null
 	add_fastest_mirror && changed=true
 fi
-- 
2.7.4

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Natanael Copa <[email-masked]>
Date: Tue, 24 Jan 2017 16:58:12 +0100

>  	add_fastest_mirror && changed=true

I dont think we should pull in gnu wget since we then would need to
have it on the iso.

I think there is a wget --spider option that should work for busybox too.

https://git.busybox.net/busybox/commit/?id=2972e2c4acb9c46a8cc05c857acac2b3d439bf69

-nc

---

---

From: Leonardo Arena <[email-masked]>
Date: Tue, 24 Jan 2017 17:10:45 +0100

> https://git.busybox.net/busybox/commit/?id=2972e2c4acb9c46a8cc05c857a

Well, edge still has 1.26. So I did it with what was available :)
Nice option though!

Thanks

-|_eo

---

From: Leonardo Arena <[email-masked]>
Date: Wed, 25 Jan 2017 08:19:10 +0100

On mar, 2017-01-24 at 17:10 +0100, Leonardo Arena wrote:
> > >  		nslookup $(get_hostname_from_url $url)
> > > >/dev/null
> > > 2>&1
> > I think there is a wget --spider option that should work for
> > busybox
> > too.
> > 
> > https://git.busybox.net/busybox/commit/?id=2972e2c4acb9c46a8cc05c85
> > 7a
> > cac2b3d439bf69
> > 
> > -nc
> 

I misread the commit message like there was version 1.28 out, but
instead it talks about GNU wget 1.18.
I guess I shouldn't look at this stuff when I'm in rush to the end of
working day :-)

-|_eo