Subject: Re: [alpine-devel] Re: help: freepbx install on alpine linux

From: Kenny Aral <[email-masked]>
Date: Fri, 30 Apr 2010 15:52:56 -0400 (EDT)

Sorry about that. Try this link: 
http://docs.google.com/fileview?id=0B7wCC8VkuTlvNWY0NzgzYjctYmYyMC00MzVjLWFjMzctZjE1Y2ZlNDk0ZmNh&hl=en

On Fri Apr 30 07:39:47 EDT 2010, Carlo Landmeter 
<[email-masked]> wrote:

> Glad you managed to make it work. I tried to view your document 
> but
> the Google link doesn't work for me.
> 
> Carlo
> 
> On Thu, Apr 29, 2010 at 9:49 PM, Kenny Aral <[email-masked]> 
> wrote:
>> I would like to thank all of you for your help with this 
>> project. I really
>> appreciate the time you took to provide helpful suggestions to 
>> the problems
>> I was having. I have completed the installation and I now have a 
>> working web
>> server with FreePBX and Asterisk installed on Alpine Linux. I 
>> will work on
>> putting my installation procedure on the Alpine Linux Wiki, but 
>> if you are
>> interested, you can read the paper I wrote for this project here:
>> https://docs.google.com/fileview?id=0B7wCC8VkuTlvNWY0NzgzYjctYmYyMC00MzVjLWFjMzctZjE1Y2ZlNDk0ZmNh&hl=en
>> 
>> The final solution to the most recent problem that I was having 
>> with the
>> MySQL database connection was to use a UNIX socket connection 
>> instead of
>> TCP. To do this, I had to designate the host as
>> unix(/var/run/mysqld/mysqld.sock).
>> 
>> On Mon Apr 26 02:12:30 EDT 2010, Harry Lachanas 
>> <[email-masked]> wrote:
>> 
>>> Kenny Aral wrote:
>>>> 
>>>> Thanks for the suggestion, Harry. That corrected the error I 
>>>> was getting.
>>>> However, now I am getting a new error that I've spent the 
>>>> whole day trying
>>>> to fix. I have created the MySQL databases called asterisk and
>>>> asteriskcdrdb. I granted all privileges using:
>>>> 
>>>> mysql> grant all privileges on asterisk.* to 
>>>> asteriskuser@localhost
>>>> identified by 'amp109';
>>>> mysql> grant all privileges on asteriskcdrdb.* to 
>>>> asteriskuser@localhost
>>>> identified by 'amp109';
>>>> mysql> flush privileges;
>>>> 
>>>> When I run the script the output is:
>>>> 
>>>> # ./install_amp
>>>> ...
>>>> ...
>>>> Connecting to database..FAILED
>>>> DB Error: connect failed, [nativecode=No such file or 
>>>> directory] **
>>>> mysql://asteriskuser:amp109@localhost/asterisk
>>>> Try running ./install_amp --username=user -password=pass
>>>> [FATAL] Cannot connect to database
>>>> 
>>>> I don't understand why its giving me a "no such file" error 
>>>> when the
>>>> database definitely exists. If I change the IP address from 
>>>> 'localhost' to
>>>> the actually IP address of the server I am running 
>>>> '192.168.1.114' the
>>>> output is:
>>>> 
>>>> # ./install_amp
>>>> ...
>>>> ...
>>>> Connecting to database..FAILED
>>>> DB Error: connect failed, [nativecode=Connection refused] **
>>>> mysql://asteriskuser:[email-masked]/asterisk
>>>> Try running ./install_amp --username=user -password=pass
>>>> [FATAL] Cannot connect to database
>>>> 
>>>> This time I get "Connection refused." I have tried running the 
>>>> script
>>>> with --skip networking uncommented/commented in 
>>>> /etc/mysql/my.cnf with no
>>>> success. At this point I'm stumped as to why its not working. 
>>>> This is the
>>>> very last part of the installation too.
>>>> 
>>>> On Fri Apr 23 02:27:55 EDT 2010, Harry Lachanas 
>>>> <[email-masked]>
>>>> wrote:
>>> 
>>> grant all privileges on asterisk.* to asteriskuser@localhost 
>>> identified by
>>> 'amp109';
>>> 
>>> with this statement you allow asteriskuser to connect to 
>>> database only
>>> from local host ( 127.0.0.1)
>>> 
>>> try to place the ip address of the alpine box you have asterisk 
>>> running
>>> ...
>>> 
>>> that is on mysql server
>>> grant all privileges on asterisk.* to 
>>> asteriskuser@ALPINE_IP_ADDRESS
>>> identified by 'amp109';
>>> 
>>> or any host
>>> 'asteriskuser'@'%'
>>> 
>>> Can you connect from a remote box to your mysql server from lan 
>>> ???
>>> 
>>> Make sure that you can, and proceed ..
>>> 
>>> Cheers
>>> You R almost done .
>>> 
>>> 
>>> 
>>> 
>> 
>> 
>> 
>> --
>> ARAL,KENNY A
>> 
>> 
>> 
>> ---
>> Unsubscribe: ??[email-masked]
>> Help: ?? ?? ?? ?? [email-masked]
>> ---
>> 
>> 
> 
> 

--
ARAL,KENNY A

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Carlo Landmeter <[email-masked]>
Date: Wed, 12 May 2010 17:45:10 +0200

Hi,

There were some issues in AlpineLinux which prevented a clean/nice
install of FreePBX. I think I've fixed most of those issues in edge
repo and have created a wiki doc on how to setup FreePBX on
AlpineLinux

http://wiki.alpinelinux.org/wiki/Freepbx_on_AlpineLinux

This is just a rough cp doc, if anyone wants to improve it go ahead.

carlo

On Fri, Apr 30, 2010 at 9:52 PM, Kenny Aral <[email-masked]> wrote:
> On Fri Apr 30 07:39:47 EDT 2010, Carlo Landmeter <[email-masked]>
> wrote:
>
>> Glad you managed to make it work. I tried to view your document but
>> On Thu, Apr 29, 2010 at 9:49 PM, Kenny Aral <[email-masked]> wrote:
>>>
>>> I would like to thank all of you for your help with this project. I
>>> really
>>> appreciate the time you took to provide helpful suggestions to the
>>> problems
>>> I was having. I have completed the installation and I now have a working
>>> web
>>> server with FreePBX and Asterisk installed on Alpine Linux. I will work
>>> on
>>> putting my installation procedure on the Alpine Linux Wiki, but if you
>>> are
>>> The final solution to the most recent problem that I was having with the
>>> MySQL database connection was to use a UNIX socket connection instead of
>>> On Mon Apr 26 02:12:30 EDT 2010, Harry Lachanas <[email-masked]>
>>> wrote:
>>>
>>>> Kenny Aral wrote:
>>>>>
>>>>> Thanks for the suggestion, Harry. That corrected the error I was
>>>>> getting.
>>>>> However, now I am getting a new error that I've spent the whole day
>>>>> trying
>>>>> mysql> grant all privileges on asterisk.* to asteriskuser@localhost
>>>>> identified by 'amp109';
>>>>> DB Error: connect failed, [nativecode=No such file or directory] **
>>>>> I don't understand why its giving me a "no such file" error when the
>>>>> database definitely exists. If I change the IP address from 'localhost'
>>>>> to
>>>>> the actually IP address of the server I am running '192.168.1.114' the
>>>>> output is:
>>>>>
>>>>> # ./install_amp
>>>>> ...
>>>>> ...
>>>>> This time I get "Connection refused." I have tried running the script
>>>>> with --skip networking uncommented/commented in /etc/mysql/my.cnf with
>>>>> no
>>>>> success. At this point I'm stumped as to why its not working. This is
>>>>> the
>>>>> On Fri Apr 23 02:27:55 EDT 2010, Harry Lachanas <[email-masked]>
>>>>> wrote:
>>>>
>>>> grant all privileges on asterisk.* to asteriskuser@localhost identified
>>>> by
>>>> 'amp109';
>>>>
>>>> with this statement you allow asteriskuser to connect to database only
>>>> try to place the ip address of the alpine box you have asterisk running
>>>> ...
>>>>
>>>> that is on mysql server
>>>> grant all privileges on asterisk.* to asteriskuser@ALPINE_IP_ADDRESS
>>>> identified by 'amp109';
>>>>
>>>> or any host
>>>> 'asteriskuser'@'%'
>>>>
>>>> Can you connect from a remote box to your mysql server from lan ???
>>>>

---