Subject: [alpine-devel] No keyboard and no mouse with X

From: Etienne <[email-masked]>
Date: Sun, 2 Apr 2017 21:42:36 +0100

Hello list,

I'm currently trying Alpine linux, but I get a slight annoyance: no 
matter what xf86-input-* package I add, on the three laptops I tried, I 
never get the integrated keyboard and touchpad to work under X (the 
keyboard is fine in the console), only a USB keyboard and a USB mouse work.

I have been following these instructions: 
https://wiki.alpinelinux.org/wiki/XFCE_Setup, XFCE launches fine, the 
resolution is correct, and the list of relevant packages installed is 
the following:

|    # apk info | grep xf86 | sort
|    libxxf86vm
|    xf86-input-evdev
|    xf86-input-evdev-dev
|    xf86-input-evdev-doc
|    xf86-input-keyboard
|    xf86-input-keyboard-doc
|    xf86-input-mouse
|    xf86-input-mouse-dev
|    xf86-input-mouse-doc
|    xf86-input-synaptics
|    xf86-input-vmmouse
|    xf86-input-vmmouse-doc
|    xf86-video-ati
|    xf86-video-fbdev
|    xf86-video-i128
|    xf86-video-modesetting
|    xf86-video-r128
|    xf86-video-vesa

Am I missing something? The three laptops I tried are old and new 
Thinkpads, a t460s, an X100e, and an X120e, if that matters. Also, in 
the output of dmesg, just after running startx, there's the following 
(not sure that matters):

|    [ 1053.907895] grsec: denied resource overstep by requesting 21 for 
RLIMIT_NICE against limit 0 for /usr/bin/xinit[xinit:2955] 
uid/euid:1000/1000 gid/egid:1000/
1000, parent /usr/bin/startx[startx:2930] uid/euid:1000/1000 
gid/egid:1000/1000

I'm not sure where to look to solve this. Has anyone a clue about what I 
should do?

Cheers,

-- 

Étienne

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Leonardo Arena <[email-masked]>
Date: Mon, 3 Apr 2017 15:11:29 +0200

Hi,

> keyboard is fine in the console), only a USB keyboard and a USB mouse work.

anything relevant in Xorg.0.log?

|_eo

---

From: Étienne <[email-masked]>
Date: Mon, 3 Apr 2017 23:13:53 +0100

> anything relevant in Xorg.0.log?
There was nothing. It was rather the absence of devices that was 
striking. But I got another tip and sorted it out. Thanks anyway.

-- 
Étienne

---