Subject: [alpine-devel] make mysql use uclibc++-dev

From: "Carlo Landmeter" <[email-masked]>
Date: Sun, 08 Feb 2009 21:29:33 +0000

see attached  git patch

carlo

From c90e35a5d44c7be2a2708754d64e498a3e3e96b9 Mon Sep 17 00:00:00 2001
From: Carlo Landmeter <[email-masked]>
Date: Sun, 8 Feb 2009 21:27:43 +0000
Subject: [PATCH] testing/mysql: uclibc++-dev is fixed

---
 testing/mysql/APKBUILD |    4 ++--
 1 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/testing/mysql/APKBUILD b/testing/mysql/APKBUILD
index 7724f45..f40b3fd 100644
--- a/testing/mysql/APKBUILD
+++ b/testing/mysql/APKBUILD
@@ -5,8 +5,8 @@ pkgrel=1
 pkgdesc="A fast SQL database server"
 url="http://www.mysql.com/"
 license='GPL'
-depends="g++ readline openssl"
-makedepends="libtool g++ readline-dev openssl-dev"
+depends="readline openssl"
+makedepends="libtool uclibc++-dev readline-dev openssl-dev"
 source="http://sunsite.informatik.rwth-aachen.de/mysql/Downloads/MySQL-5.0/${pkgname}-${pkgver}.tar.gz
 $pkgname.initd
 $pkgname.mycnf"
-- 
1.6.1

---

From: Natanael Copa <[email-masked]>
Date: Mon, 09 Feb 2009 10:20:23 +0100

> carlo

you need to add uclibc++ to depends and insert an

   export CXX=g++-uc

before ./configure in order to use link against uclibc++.

I'll do that and commit.

Thanks!

-nc

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---