Subject: [alpine-devel] testing/prosody: adding default config

From: "Mika Havela" <[email-masked]>
Date: Wed, 10 Jun 2009 14:22:32 +0000

Previous APKBUILD didn't apply the default config.
This is now fixed.
Please review and apply.

This packge is tested and it works.
It still would work even better with luasec (which doesn't exist yet - but I try fixing it as soon as possible).

<<mhavela>>

From e177eb6b56841606614717776716cfcef10ea92c Mon Sep 17 00:00:00 2001
From: Linux User <mhavela@mh-devlab1.(none)>
Date: Wed, 10 Jun 2009 14:12:52 +0000
Subject: [PATCH] testing/prosody: creating/activating default config
 You will still need to edit the config to fit your needs, but with this config
 you can at least start prosody.

---
 testing/prosody/APKBUILD        |    1 +
 testing/prosody/prosody.cfg.lua |    1 +
 2 files changed, 2 insertions(+), 0 deletions(-)

diff --git a/testing/prosody/APKBUILD b/testing/prosody/APKBUILD
index f4ef147..0637b64 100644
--- a/testing/prosody/APKBUILD
+++ b/testing/prosody/APKBUILD
@@ -21,6 +21,7 @@ build() {
 	cd "$srcdir/$pkgname-$pkgver"
 
 	patch Makefile "$startdir/Makefile-0.4.2.patch" || return 1
+	install -D -m755 "$srcdir"/"$pkgname".cfg.lua "$pkgdir"/etc/prosody/"$pkgname".cfg.lua
 
 	./configure --prefix=/usr \
 		--sysconfdir=/etc/prosody \
diff --git a/testing/prosody/prosody.cfg.lua b/testing/prosody/prosody.cfg.lua
index 99df66a..37bafc1 100644
--- a/testing/prosody/prosody.cfg.lua
+++ b/testing/prosody/prosody.cfg.lua
@@ -87,6 +87,7 @@ Host "*"
 
 -- This allows clients to connect to localhost. No harm in it.
 Host "localhost"
+	allow_registration = yes
 
 -- Section for example.com
 -- (replace example.com with your domain name)
-- 
1.6.2.5

---

From: Mika Havela <[email-masked]>
Date: Wed, 10 Jun 2009 16:25:30 +0200

Sorry... I have rebuilt my dev-environment. The previous patch didn't
hold the right author information (committed as 'root')
Please skip it. I resend a new.
<<mhavela>>

> It still would work even better with luasec (which doesn't exist yet - but I try fixing it as soon as possible).

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---