1

[alpine-devel] unstable/trac, testing/py-genshi, testing/py-sqlite: Making trac work with edge

Mika Havela
Details
Message ID
<20100601092042.E7C0337E4A@smtp3-1-sn3.vrr.skanova.net>
Sender timestamp
1275384042
DKIM signature
missing
Download raw message
These patches makes trac work with edge.
trac version is updated.
I have not tried backport this to 1.10 (but I would be really glad to have trac in 1.10.4 - if there ever will be a 1.10.4).
py-genshi and py-sqlite is required for trac to work, so please apply theese too.

Running trac as root:
Trac in Alpine 1.8.3 was run as root so nothing has changed there right now.
I think it would be a good idea to have it run as som other user, but I have not had time to do anything about it.
Right now I run trac as root in a test box and it seems to work just fine.
Hopefully somebody else can make a patch that makes trac run as somebody else, or you wait for me to get the time to fix it.

unstable/trac > testing/trac:
I would really love having trac moved to "testing".
If it's ok with you, could you please move trac to testing.

Please review and apply theese patches.

<<mhavela>>

Re: [alpine-devel] unstable/trac, testing/py-genshi, testing/py-sqlite: Making trac work with edge

Natanael Copa
Details
Message ID
<AANLkTilpheRk_cY9xZw0cEC5ifBZDyup3EGW85OY0RLJ@mail.gmail.com>
In-Reply-To
<20100601092042.E7C0337E4A@smtp3-1-sn3.vrr.skanova.net> (view parent)
Sender timestamp
1275392894
DKIM signature
missing
Download raw message
On Tue, Jun 1, 2010 at 11:20 AM, Mika Havela <mika.havela@gmail.com> wrote:
>
> These patches makes trac work with edge.

Wonderful!

> trac version is updated.
> I have not tried backport this to 1.10 (but I would be really glad to have trac in 1.10.4 - if there ever will be a 1.10.4).

hum. we need make it *stable* before even considering put it in 1.10.x.

> py-genshi and py-sqlite is required for trac to work, so please apply theese too.

notes on py-sqlite:
* the web page in url does not exist. http://initd.org/tracker/pysqlite
* License is MIT according http://code.google.com/p/pysqlite/
* there is no package() function. Have build() to run: 'python
setup.py build' and package() to run 'python setup.py install
--root="$pkgdir"'
* I don't think you need have sqlite in depends (if you get a warning
about it then please remove it)

> Running trac as root:
> Trac in Alpine 1.8.3 was run as root so nothing has changed there right now.
> I think it would be a good idea to have it run as som other user, but I have not had time to do anything about it.
> Right now I run trac as root in a test box and it seems to work just fine.
> Hopefully somebody else can make a patch that makes trac run as somebody else, or you wait for me to get the time to fix it.
> unstable/trac > testing/trac:
> I would really love having trac moved to "testing".
> If it's ok with you, could you please move trac to testing.

yes. "unstable" shouldnt have been there in first place. If it builds
then we can move it to testing.

> Please review and apply theese patches.

Can you please fix the following:
1. fix the py-sqlite as menitioned above: fix url, fix license and add
a package() function.
2. add package() functions to py-genshi and trac as well (if possible)
3. move trac to testing

and the resend the patches?

Thanks!

-- 
Natanael Copa


---
Unsubscribe:  alpine-devel+unsubscribe@lists.alpinelinux.org
Help:         alpine-devel+help@lists.alpinelinux.org
---