Subject: Re: [alpine-devel] NOT SPAM xulrunner build report

From: Natanael Copa <[email-masked]>
Date: Fri, 25 Feb 2011 13:13:18 +0000

On Fri, 25 Feb 2011 05:35:00 +0000
"AlpineBuildBot" <[email-masked]> wrote:
> (4/14) Installing fts-doc (0-r2)
> ERROR: fts-doc: Trying to overwrite usr/share/man/man3/fts.3 owned by
> man-pages. ERROR: /home/amanison/.cache/apks/fts-doc-0-r2.apk:
> Operation not permitted

Andrew: I don't think you should have man-pages installed on the build
bot.

-nc

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Andrew Manison <[email-masked]>
Date: Fri, 25 Feb 2011 14:34:06 -0500

Thanks Nataneal, that seemed to fix a bunch of them. Now I have just 9 
failures in main, and 6 in testing. The majority are missing source 
archives:

main/bkeymaps
main/libssh
main/lua-uuid
main/ncftp
main/opentracker
main/postgrey
main/rxmtp
main/snort
testing/appliancekit
testing/libev
testing/openxcap
testing/usb-modeswitch

If these can be fixed easily, then I will rerun the script and just the 
genuine build errors will be flagged. I will also implement a 
sourcecheck into the makefile or the script to flag these independently 
of the build. Then the build script will ignore packages which fail the 
sourcecheck and only report build errors.

There is still a bit of wooliness around the dependencies, and I find 
that from a clean build I have to run the script a couple of times to 
get everything built. But this is a minor gripe, and no hardship.

Andrew

On 2/25/2011 8:13 AM, Natanael Copa wrote:
> "AlpineBuildBot"<[email-masked]>  wrote:

---

From: Natanael Copa <[email-masked]>
Date: Sun, 27 Feb 2011 13:23:51 +0000

On Fri, 25 Feb 2011 14:34:06 -0500
Andrew Manison <[email-masked]> wrote:

>   Thanks Nataneal, that seemed to fix a bunch of them. Now I have
> just 9 failures in main, and 6 in testing. The majority are missing
> source archives:
> 
> main/bkeymaps
fixed.

> main/libssh
seems to have disappeared upstream? got it from gentoo distfiles for
now.
fixed.

> main/lua-uuid
fixed.

> main/ncftp
clandmeters (I think its outdated too)

> main/opentracker
fixed

> main/postgrey
ms13sp's (also outdated)

> main/rxmtp
fixed.

> main/snort
fixed.

> testing/appliancekit
seems like bitbucket redirects to https (which bb wget does not
support) and it seems like the release url source package have changed.
Gives different checksum. Latest release seems to be fairly old to. I
remove this for now.

> testing/libev
fixed.

> testing/openxcap
fcolista's

> testing/usb-modeswitch
rnalrd's

> 
> If these can be fixed easily, then I will rerun the script and just
> the genuine build errors will be flagged. I will also implement a 
> sourcecheck into the makefile or the script to flag these
> independently of the build. Then the build script will ignore
> packages which fail the sourcecheck and only report build errors.
> 

Thanks!

-nc

---

---

From: Francesco <[email-masked]>
Date: Sun, 27 Feb 2011 16:47:34 +0100

> fcolista's

Fixed openxcap APKBUILD.
Is on fcolista's git report, please review and commit.
Thanks.

-- 
:: Francesco ::
Jabber: [email-masked]
E-Mail: [email-masked]
GnuPG: FE9DDD5F

---