Subject: [alpine-devel] deleting main/abuild: Patch to delete sources with bad md5sum

From: Natanael Copa <[email-masked]>
Date: Sat, 5 Mar 2011 09:21:37 +0000

Hi,

I am deleting the patch added with aports
f6e1791e9c37fb946bcfd6b685b12f5cda5ef7bf

I do it because that will delete *all* sources for the package if any
file have bad md5sum. For example, if I work on a gcc patch, edit the
patch, and run abuild, it will fail on the md5sum check (because i
forgot to abuild checksum first). This results that all gcc sources
gets deleted and needs to be downloaded again (~50M).

I'm not against the idea of deleting files that fails on md5check, but
it should only delete the file(s) that fails. Not all.

-nc

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Ted Trask <[email-masked]>
Date: Sat, 5 Mar 2011 07:29:52 -0800 (PST)

That's fine by me. I never claimed to know what I was doing, but the patch saved 
me when you were gone. :)

I still think it's a good idea to delete packages that downloaded with errors, 
especially for the build server. Unless you want to give access to the build 
servers to all of us developers. Or promise to never go on vacation again. :)

Ted

----- Original Message ----
From: Natanael Copa <[email-masked]>
To: [email-masked]; Ted Trask <[email-masked]>
Sent: Sat, March 5, 2011 4:21:37 AM
Subject: [alpine-devel] deleting main/abuild: Patch to delete sources with bad 
md5sum

Hi,

-nc

---

---

---

From: Jeremy Thomerson <[email-masked]>
Date: Fri, 25 Mar 2011 21:47:10 -0400

I was going to take a look at this patch and see if I could fix it up to
work as described, but didn't find it in the abuild git repo.  Am I just
missing it?

Jeremy Thomerson

---

From: Jeremy Thomerson <[email-masked]>
Date: Fri, 25 Mar 2011 23:31:17 -0400

Well, I took a stab at it.  Patch email was sent separately.  See if that's
what you were looking for.  It's not a really elegant solution, but it seems
to work.  Let me know what you think (you can reply directly to the patch
thread).

Jeremy Thomerson