Subject: Re: [alpine-devel] NOT SPAM perl-tree-simple build report

From: Natanael Copa <[email-masked]>
Date: Wed, 28 Dec 2011 08:41:57 +0100

On Mon, 26 Dec 2011 08:49:59 +0000
"AlpineBuildBot" <[email-masked]> wrote:

> >>> perl-tree-simple:
> >>> Unpacking /home/amanison/aports/main/perl-tree-simple/Tree-Simple-1.18.tar.gz...  
> Checking if your kit is complete...
> Looks good
> Writing Makefile for Tree::Simple
> Writing MYMETA.yml
> cp lib/Tree/Simple.pm blib/lib/Tree/Simple.pm
> cp lib/Tree/Simple/Visitor.pm blib/lib/Tree/Simple/Visitor.pm
> Manifying blib/man3/Tree::Simple::Visitor.3pm
> Manifying blib/man3/Tree::Simple.3pm
> PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e"
> "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
> t/10_Tree_Simple_test.t ............. ok
> t/11_Tree_Simple_fixDepth_test.t .... ok Can't locate Sub/Uplevel.pm
> in @INC (@INC
> contains: /home/amanison/aports/main/perl-tree-simple/src/Tree-Simple-1.18/blib/lib /home/amanison/aports/main/perl-tree-simple/src/Tree-Simple-1.18/blib/arch /usr/local/lib/perl5/site_perl /usr/local/share/perl5/site_perl /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/core_perl /usr/share/perl5/core_perl .)
> at /usr/share/perl5/vendor_perl/Test/Exception.pm line 6. BEGIN
> failed--compilation aborted
> at /usr/share/perl5/vendor_perl/Test/Exception.pm line 6. Compilation
> failed in require at t/12_Tree_Simple_exceptions_test.t line 7.

I am not able to reproduce this. And I cannot find any Sub/Uplevel.pm
on my system(s).

-nc

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Andrew Manison <[email-masked]>
Date: Thu, 29 Dec 2011 04:13:36 -0500

I found the problem and fixed it in my repo. perl-sub-uplevel was 
missing from cpandepends. I don't know why it was a problem on my setup 
but not yours. You can merge the change if it checks out.

There are a couple of other changes to packages there, as well as a new 
one in testing: nfdump.

Let me know if you prefer that I submit these changes by email.

On 12/28/2011 2:41 AM, Natanael Copa wrote:
> "AlpineBuildBot"<[email-masked]>  wrote:
>
>>>>> perl-tree-simple:

---

---

From: Natanael Copa <[email-masked]>
Date: Fri, 30 Dec 2011 10:25:26 +0100

On Thu, 29 Dec 2011 04:13:36 -0500
Andrew Manison <[email-masked]> wrote:

...

> There are a couple of other changes to packages there, as well as a
> new one in testing: nfdump.
> 

You have them in your amanison/aports.git repo. I have cherry-picked
rrdtool and nfdump changes. Please let me know if there are other
changes you want me cherry-pick. I will not merge the tree since I
don't think the .gitignore should hold any *.patches.

I should probably make abuild force SRCDEST so we avoid downloading to
current dir.

Thanks for working on this!

-nc

---