Subject: [alpine-devel] New role for maintainers in bugs.a.o

From: Natanael Copa <[email-masked]>
Date: Thu, 19 Jan 2012 08:55:04 +0100

Hi,

I have added a new role: "Aports Maintainers" to bugs.a.o. It is
mainly because I need to be able to assigns issues to the maintainers.

I am not completely sure how to do the maintainer workflow, but I think
something like this:

1. a bug report is created
2. the maintainer gets assigned
3. the maintainer fix it and creates a patch
4. a developer commits it

The patch can/should include "fixes #NNN"  in the commit message if it
fixes the issue or "ref #NNN" if it is related an issue.

This also means, to become an aports maintainer you need a login on
bugs.a.o and you need to be assigned the role "Aports Maintainer"

I am open for ideas and suggestions.

Thanks!

 -nc

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Jeremy Thomerson <[email-masked]>
Date: Thu, 19 Jan 2012 08:05:36 -0500

> 4. a developer commits it

Works for me.  Do I need to do anything special to get email notification
of tickets that are assigned to me (since I don't regularly read bugs.a.o)?

> bugs.a.o and you need to be assigned the role "Aports Maintainer"

Please add: jrthomerson

--
Jeremy Thomerson

---

From: Natanael Copa <[email-masked]>
Date: Thu, 19 Jan 2012 14:17:15 +0100

On Thu, 19 Jan 2012 08:05:36 -0500
Jeremy Thomerson <[email-masked]> wrote:

> > I am not completely sure how to do the maintainer workflow, but I
> > think something like this:
> >
> Works for me.  Do I need to do anything special to get email
> notification of tickets that are assigned to me (since I don't
> regularly read bugs.a.o)?

On your profile the "Email notification" setting is currently set to
"Only for things I watch or are involved with"

So you are supposed to get email notifications for things that gets
assigned to you, and things you comment on etc.
 
> > The patch can/should include "fixes #NNN"  in the commit message if
> > it fixes the issue or "ref #NNN" if it is related an issue.
> >

done. Thanks!

-nc

---