Subject: [alpine-devel] help text for setup-interfaces

From: Natanael Copa <[email-masked]>
Date: Thu, 22 Mar 2012 21:02:12 +0100

Hi,

I have implemented bridge support for setup-interfaces. You can now
enter 'br0' or 'bridge0' and it will ask what interfaces it should add
to the bridge.

The changes are available in git.

I need help with the help text, when entering '?'. How do I explain
that you can either enter one of the listed available interfaces, or a
non-liste bridge, and later I will add bonding and vlans.

Ideas?

Thanks!

-nc

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Nathan Angelacos <[email-masked]>
Date: Thu, 22 Mar 2012 22:21:51 -0700

> non-liste bridge, and later I will add bonding and vlans.

Select the interface you wish to configure.

For advanced configurations, you can also enter:
br[0-9]+   	(ex: br0)	bridge interface
bridge[0-9]+   	(ex: bridge0)	bridge interface
bond[0-9]+ 	(ex: bond32)	teamed/bonded interface
vlan[0-9]+ 	(ex: vlan371)	vlan interface

You will be asked which physical interface(s) to
be used for advanced configurations.

---