Subject: [alpine-devel] Initial APKBUILD for avfs

From: "V.Krishn" <[email-masked]>
Date: Sun, 22 Apr 2012 12:54:54 +0530

Initial APKBUILD for avfs

A Virtual File System for looking into archives

----------------
# Contributor: V.Krishn <[email-masked]>
# Maintainer: 
pkgname=avfs
pkgver=1.0.0
pkgrel=0
pkgdesc="A Virtual File System for looking into archives"
url="http://avf.sourceforge.net/"
arch="all"
license="GPL"
depends=""
depends_dev=""
makedepends="bash zlib-dev bzip2-dev fuse-dev"
install=""
subpackages=""
source="http://space.dl.sourceforge.net/project/avf/$pkgname/$pkgver/$pkgname-$pkgver.tar.bz2"

_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
	cd "$_builddir"
}

build() {
	cd "$_builddir"
	./configure --enable-fuse --enable-library --prefix=/usr
	make || return 1
}

package() {
	cd "$_builddir"
	make DESTDIR="$pkgdir" install || return 1
	rm "$pkgdir"/usr/lib/*.la
	rm "$pkgdir"/usr/lib/*.a
}

md5sums="c58421e4f294125895f2c6653a7366a7  avfs-1.0.0.tar.bz2"
----------------

-- 
Regards.
V.Krishn

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Leonardo Arena <[email-masked]>
Date: Mon, 23 Apr 2012 09:51:45 +0200

> A Virtual File System for looking into archives

Hi,

thank you for contributing to Alpine. The APKBUILD looks correct.
It will go to testing repo until it's reported to work fine and it
will have a maintainer.
Would if be a problem for you to resend it using "git --send-mail"?

http://wiki.alpinelinux.org/wiki/Development_using_git

If you can't, I'll just push this manually.

Thank you

- leonardo

---