Subject: [alpine-devel] Why musl libc

From: Natanael Copa <[email-masked]>
Date: Mon, 24 Mar 2014 13:55:47 +0100

Hi,

As previously mentioned we are moving to musl libc[1].

Some might ask why so I'll write down some reasons why we do this:

* uClibc is too slow on making releases.

* uClibc code is a bit messy and some issues we have is simply not
  worth fixing with uClibc code base. (locales, static linking with
  pthreads[2])

* musl is well maintained upstream

* musl has clean codebase and lots legacy code is removed.

* musl has focus on strictness which helps us find obscure bugs.

* we work on ARM port and rather than fix uClibc we work with musl
  which has cleaner codebase.

-nc

[1] http://www.musl-libc.org/
[2] http://bugs.alpinelinux.org/issues/1579

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Natanael Copa <[email-masked]>
Date: Tue, 25 Mar 2014 14:07:12 +0100

On Mon, 24 Mar 2014 13:55:47 +0100

> Some might ask why so I'll write down some reasons why we do this:

...
 
>   worth fixing with uClibc code base. (locales, static linking with

Another thing we can do after switching to musl is supporting all
timezones. With uClibc we cannot.

http://bugs.alpinelinux.org/issues/927

-nc

---