Subject: [alpine-devel] switching to musl

From: Natanael Copa <[email-masked]>
Date: Wed, 2 Apr 2014 11:02:25 +0200

Hi,

I wonder if there are anything that prevents us from switching edge to
musl now?

The list of packages that does not build on x86_64 are:

coova-chilli
cowdancer
cups-filters
drbd
dvgrab
ebtables
flashrom
freeswitch
gnome-panel
gnome-screensaver
gnome-session
gnome-settings-daemon
gst-plugins-bad
iputils
js
kbd
libgnome-keyring
libspf2
ntop
ocfs2-tools
open-iscsi
open-vm-tools
oprofile
pcmciautils
py-libvirt
reiserfsprogs
socat
uboot-mkimage
ufsutils
util-vserver
valgrind
xbmc
xfce4-power-manager
xl2tpd
zoneminder

The list does not include any packages that depend on anything above.

Those will not be included in 3.0 unless we fix them. If anyone have
opinion what should be prioritized, please let us know.

It might also be an idea to look over what is in testing and see if
there is anything there we need for 3.0 release. Then its time to move
it to main.

Thanks!

-nc

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Jeff Pohlmeyer <[email-masked]>
Date: Wed, 2 Apr 2014 08:05:33 -0500

On Wed, Apr 2, 2014 at 4:02 AM, Natanael Copa wrote:

> I wonder if there are anything that prevents us from switching
> edge to musl now?

I had problems with the xf86-video drivers (vesa, nouveau, fbdev) not
finding symbols in the Xorg executable.

Tried to work around this by LD_PRELOAD'ing the binary, but that led
to more missing symbols.

After getting everything listed in LD_PRELOAD, the Xorg server still
would not start because of a segfault in xkbcomp.

Has anyone else had any luck running Xorg under musl?

Thanks,
 - Jeff

---

---

From: Natanael Copa <[email-masked]>
Date: Wed, 2 Apr 2014 15:29:12 +0200

On Wed, 2 Apr 2014 08:05:33 -0500

> Tried to work around this by LD_PRELOAD'ing the binary, but that led

This should fix it:
http://git.alpinelinux.org/cgit/aports/commit/main/xorg-server?id=2d5f088aeb37d13fb9893ec5da4bd683f5b4e0f0

The problem is that musl does not support lazy loading so we have to
tell xorg what order to load the modules.

> Has anyone else had any luck running Xorg under musl?

I use it on my laptop now yes. firefox needs start with
LD_PRELOAD=/usr/lib/libGL.so.1.2.0 firefox

and i haven't got dhcpcd work with wpa_supplicant so i use udhcpcd for
now. (and sometimes i need to manually ifup wlan0)

Other issue I have is that only way to connect to bluez over dbus is as
root. I haven't had time to troubleshoot but it might be a bug in dbus,
consolekit or polkit or all 3.

-nc

---

---

From: Jeff Pohlmeyer <[email-masked]>
Date: Thu, 3 Apr 2014 08:23:30 -0500

On Wed, Apr 2, 2014 at 8:29 AM, Natanael Copa wrote:
> On Wed, 2 Apr 2014 Jeff Pohlmeyer wrote:

> http://git.alpinelinux.org/cgit/aports/commit/main/xorg-server?id=2d5f088aeb37d13fb9893ec5da4bd683f5b4e0f0

Excellent!

Actually I already had that update, but I am using an old-fashioned single
xorg.conf file, so I had to copy/paste the new "Module" section into my
xorg.conf to get it working.

As an added bonus, the "column" command from  util-linux has always been
horribly broken with uclibc, but it's working great with musl!

This might not be the right place to bring it up, but I ran into a couple
of issues with the "definitive guide" page at kaniini.dereferenced.org ...

The page says to run:
  $ apk.static update
  $ apk.static upgrade --available --no-self-upgrade

But this doesn't seem to have any effect if package caching is enabled,
it just pulls the same old uclibc packages from the cache, so I guess
the cache needs to be purged first?

It also says to modify /etc/mkinitfs/files.d/base, but that file
no longer exists, it is now /etc/mkinitfs/features.d/base.files.

To be honest, I was afraid the musl switch might be a disaster, but I'm
now becoming cautiously optimistic!

 - Jeff

---

---

From: Natanael Copa <[email-masked]>
Date: Thu, 3 Apr 2014 22:25:46 +0200

On Thu, 3 Apr 2014 08:23:30 -0500

> horribly broken with uclibc, but it's working great with musl!

Someone mentioned something about a bug with python3 on IRC. But when
testing with musl, bug was gone.

> the cache needs to be purged first?

This is unexpected. Might be a bug?

> no longer exists, it is now /etc/mkinitfs/features.d/base.files.

Yes, that change happened after kaniini's article. You should not need
edit anything that is related mkinitfs. (but i think there is a bug in
the post-upgrade script though, that copies .apk-new files)

> now becoming cautiously optimistic!

Yes, its scary! But the tests so far have been much better than
expected.

---

---

From: Jeff Pohlmeyer <[email-masked]>
Date: Fri, 4 Apr 2014 11:43:54 -0500

One more thing I noticed: util-linux "hwclock" segfaults on musl-x86.

 - Jeff

---