Subject: [alpine-devel] Bug in abuild default_doc?

From: Isaac Dunham <[email-masked]>
Date: Sun, 6 Jul 2014 15:04:33 -0700

Hello,
I ran into this error while trying to create a new package:
>>> sword-doc*: Preparing subpackage sword-doc...
>>> ERROR: sword-doc*: Missing /home/idunham/aports/testing/sword/pkg/sword-doc
>>> ERROR: sword*: prepare_subpackages failed
>>> ERROR: sword: all failed
>>> sword: Uninstalling dependencies...

Looking at default_doc in abuild, I see that it doesn't mkdir $subpkgdir;
it will fail by default. I'd assume that this is not the intended behavior.

The workaround is easy (call mkdir then default_doc), but I thought I'd
mention this.

Thanks,
isaac Dunham

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Isaac Dunham <[email-masked]>
Date: Sun, 6 Jul 2014 17:57:25 -0700

> The workaround is easy (call mkdir then default_doc), but I thought I'd

And it turns out the reason is that the package was installing no
documentation by default, duh.
Sorry for the noise.

But I should have it ready to submit as soon as I test a little more.
 
Thanks,
Isaac Dunham

---