Subject: [alpine-devel] Why does klogd provide logger?

From: Isaac Dunham <[email-masked]>
Date: Mon, 7 Jul 2014 21:19:09 -0700

Hello,
I noticed a week or two ago that
service crond start
would start klogd and not syslogd; since klogd only logs kernel messages and
syslogd logs application messages, I decided to investigate.

It appears that both the klogd and syslog services provide logger, but
syslog needs klogd.

So I'm wondering: shouldn't syslog be the only service providing logger,
since klogd doesn't listen to applications?

Thanks,
Isaac Dunham

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Natanael Copa <[email-masked]>
Date: Tue, 8 Jul 2014 14:31:32 +0200

On Mon, 7 Jul 2014 21:19:09 -0700

> since klogd doesn't listen to applications?

I think you are right. This is a bug.

---

---

From: Natanael Copa <[email-masked]>
Date: Tue, 15 Jul 2014 16:55:47 +0200

> since klogd doesn't listen to applications?

I pushed a fix to edge, busybox-initscript-2.2-r21. could you please
verify that it works as expected?

Thanks!

http://bugs.alpinelinux.org/issues/3156

-nc

---