Subject: [alpine-devel] Mirror or package problem?

From: Isaac Dunham <[email-masked]>
Date: Tue, 9 Sep 2014 16:19:00 -0700

Hello,
I'm using the nl.alpinelinux.org mirror; I recently tried to install
qt5-qtbase-dev and related packages (to try compiling Otter...), and
found that none of them are available.
Is this due to an FTBFS, is the git autobuild system down,
or is the mirror falling behind?

Thanks,
Isaac Dunham

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Natanael Copa <[email-masked]>
Date: Thu, 11 Sep 2014 04:47:36 +0200

> or is the mirror falling behind?

I think the x86 build failed:
http://bld1.alpinelinux.org/buildlogs/build-edge-x86/main/qt5-qtbase/qt5-qtbase-5.3.1-r0.log

It is the same issue that caused xulrunner for x86 to fail.

It is a bug in x86 musl headers and they are working on fixing it:
http://www.openwall.com/lists/musl/2014/09/10/1

-nc

---