Subject: [alpine-devel] [PATCH] testing/ddate: new aport

From: Johannes Matheis <[email-masked]>
Date: Thu, 23 Oct 2014 08:35:13 +0000

https://github.com/jomat/aports/commit/fdbba1112f8e64a4a377da49d13d200686d6c039.patch

Thanks,
Johannes

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Natanael Copa <[email-masked]>
Date: Thu, 23 Oct 2014 13:23:05 +0200

On Thu, 23 Oct 2014 08:35:13 +0000

> Help:         [email-masked]

Looks like it is GPL license?

Looks also like it is shipped with util-linux. Would it be an idea
build it with util-linux and make a subpackage for it?

-nc

---

---

From: "Johannes Matheis" <[email-masked]>
Date: Thu, 23 Oct 2014 11:47:12 +0000

Hi, 

Quoting Natanael Copa (2014-10-23 11:23:05) 
> Looks like it is GPL license? 

I'm not so sure, but I don't think it's GPL. 
man 1 ddate, section "DISTRIBUTION POLICY" reads: 
> Public domain. All rites reversed. 

And from ddate.c: 
> Reprint, reuse, and recycle what you wish. 
> This program is in the public domain. Distribute freely. Or not. 

From util-linux-2.24.2/Documentation/releases/v2.23-ReleaseNotes: 
> The command ddate has been REMOVED from util-linux. You can find it here: 
> https://github.com/bo0ts/ddate 

Thanks, 
Johannes

---