Subject: [alpine-devel] [PATCH] testing/jq: new aport

From: Johannes Matheis <[email-masked]>
Date: Wed, 5 Nov 2014 12:26:31 +0000

http://stedolan.github.io/jq/
A lightweight and flexible command-line JSON processor

Patch should be available from:
https://github.com/jomat/aports/commit/21bd9ee6afdd9ae8a7e5420feb394ea71a0c201e.patch

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Johannes Matheis <[email-masked]>
Date: Wed, 5 Nov 2014 19:01:21 +0000

https://github.com/jomat/aports/commit/162f3169be4623a0338817b1d6e617909fd3b2e6.patch

---

---

From: Natanael Copa <[email-masked]>
Date: Thu, 13 Nov 2014 08:22:51 +0100

On Wed, 5 Nov 2014 12:26:31 +0000

> https://github.com/jomat/aports/commit/21bd9ee6afdd9ae8a7e5420feb394ea71a0c201e.patch

This looks like a very nice tool. I have applied it with the libtool
fix patch as a 'fixup'.

(what i did was: git am on both, then: 'git rebase -i' and marked the
second one as a 'fixup' so it got merged into the first).

Could you please do som basic testing with edge/testing and let me know
if it works so I can move it to main before v3.1 release?

Thanks!

-nc

---

---

From: "Johannes Matheis" <[email-masked]>
Date: Sun, 16 Nov 2014 12:07:44 +0000

Hi,

Quoting Natanael Copa (2014-11-13 07:22:51)
> if it works so I can move it to main before v3.1 release?

I use it in small scripts primarily for collecting/parsing data for
monitoring purposes, they work as expected.

From http://stedolan.github.io/jq/manual/ I additionally tested ~10 of the
examples, our jq behaves with them identical to https://jqplay.org/jq, i. e.
the results of the del() and sort() ones differ with both from the expected
results of the manual.

Bye,
Johannes

---

---

From: Natanael Copa <[email-masked]>
Date: Mon, 17 Nov 2014 09:06:28 +0100

On Sun, 16 Nov 2014 12:07:44 +0000

> the results of the del() and sort() ones differ with both from the expected

Moved it to main.

This looks like a useful tool.

Thanks!

-nc

---