Subject: [alpine-devel] Could we break the mesa-dev dependency on mesa-dbg?

From: Isaac Dunham <[email-masked]>
Date: Mon, 10 Nov 2014 10:24:22 -0800

Hello,
I have several development packages installed, which drag in three -dbg
packages: glib-dbg, musl-dbg, and mesa-dbg.
In theory, I can see the logic for -dev requiring -dbg.
In practice, I've installed the Qt5 development packages to build
the Otter browser, whiich works quite well; these pull in mesa-dev,
thus pulling in mesa-dbg, which is over 100 megabytes I have absolutely 
no use for (~7% of total disk usage).

Would it be possible to make mesa-dbg an exception, due to its extremely
large installed size?

Thank you,
Isaac Dunham

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Timo Teras <[email-masked]>
Date: Tue, 11 Nov 2014 10:48:50 +0200

On Mon, 10 Nov 2014 10:24:22 -0800
Isaac Dunham <[email-masked]> wrote:

> I have several development packages installed, which drag in three
> -dbg packages: glib-dbg, musl-dbg, and mesa-dbg.
> thus pulling in mesa-dbg, which is over 100 megabytes I have
> absolutely no use for (~7% of total disk usage).
> 
> Would it be possible to make mesa-dbg an exception, due to its
> extremely large installed size?

I think it would be useful if none of the -dev packages depended on the
-dbg. It's not a dependency. And it'll made builders run faster, etc.

I think -dbg should be standalone. It's needed only when debugging a
package.

The only sensible default would be -dbg having install_if=<parent> gdb.
Though it might not be feasible to install *all* -dbg packages due to
their size. Perhaps add meta-packages "debug-info", and have install_if
against that?

/Timo

---

---

From: Natanael Copa <[email-masked]>
Date: Tue, 11 Nov 2014 12:15:32 +0100

On Tue, 11 Nov 2014 10:48:50 +0200

> I think -dbg should be standalone. It's needed only when debugging a

I agree, but unfortunally, we just built world with current behaviour and I just did RC1.

I can update abuild to not add -dbg as subpackage but then all the
packages which has -dbg needs to be rebuilt.

The list of packages are:

main/asterisk
main/claws-mail
main/dhcp
main/firefox
main/freeradius
main/freeradius3
main/glib
main/gnutls
main/kamailio
main/libnice
main/libtirpc
main/lighttpd
main/mesa
main/musl
main/nfs-utils
main/nsd
main/openvswitch
main/oscam
main/php
main/postgresql
main/quagga
main/rpcbind
main/rtapd
main/rtnppd
main/unbound
testing/firefox

Are we ok to do this before RC2?

> their size. Perhaps add meta-packages "debug-info", and have install_if

I don't think its worth it. You normally only install -dbg when you are
trying to debug a specific application.

-nc

---

---

From: Isaac Dunham <[email-masked]>
Date: Tue, 11 Nov 2014 09:26:10 -0800

> packages which has -dbg needs to be rebuilt.
<snip>
> Are we ok to do this before RC2?

I'm inclined to suggest doing it after 3.1, given where we are.

> trying to debug a specific application.

Agreed.

> -nc

Thanks,
Isaac Dunham

---

---

From: Natanael Copa <[email-masked]>
Date: Thu, 13 Nov 2014 08:52:53 +0100

On Tue, 11 Nov 2014 09:26:10 -0800

> I'm inclined to suggest doing it after 3.1, given where we are.

Good.

I removed the mesa-dbg subpackage for now to address your specific issue.

Thanks!

-nc

---