Subject: [alpine-devel] [Alpinelinux] gitolite - setup using the gitolite package

From: Orion Miller <[email-masked]>
Date: Tue, 18 Nov 2014 08:47:38 -0800

Hey all,

I am making adding  a section to gitolite Alpine wiki article. I would
like to know what are the proper post install steps to get the gitolite
server up and running.

== my guess ==
apk add openssh
# setup sshd accordingly
rc-service sshd start
su - git
gitolite setup -a <name> -pk <key.pub>
... then I am not sure much around here or beyond

---

From: Bartłomiej Piotrowski <[email-masked]>
Date: Tue, 18 Nov 2014 06:48:12 +0100

On Tue, 18 Nov 2014 08:47:38 -0800
Orion Miller <[email-masked]> wrote:
> like to know what are the proper post install steps to get the
> gitolite server up and running.
> 
> == my guess ==
> apk add openssh
> # setup sshd accordingly
> rc-service sshd start
> su - git

Hi Orion,

Sorry I haven't replied you before. The setup is quite simple and it's
already described in upstream documentation[1]. Obviously you can
skip "gitolite/install" step as it's already done by installing
gitolite package. You pretty much described the whole process.

[1] http://gitolite.com/gitolite/install.html#qi

-- 
Bartłomiej Piotrowski