Subject: [alpine-devel] qemu without gtk/sdl

From: Natanael Copa <[email-masked]>
Date: Wed, 26 Nov 2014 13:28:34 +0100

I'd like to disable GTK/SDL from qemu build. Any objections?

-nc

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Isaac Dunham <[email-masked]>
Date: Wed, 26 Nov 2014 08:47:35 -0800

> I'd like to disable GTK/SDL from qemu build. Any objections?
Will there be a GUI included with qemu by default?
While in the past I've written a wrapper to use a VNC client with qemu,
it's nice to be able to just run qemu ... and have a working framebuffer.

Alternately, is there some wrapper that is equivalent to that?

(I haven't used qemu much on Alpine, though.)

Thanks,
Isaac Dunham

---

---

From: Natanael Copa <[email-masked]>
Date: Wed, 26 Nov 2014 23:03:28 +0100

On Wed, 26 Nov 2014 08:47:35 -0800

> Will there be a GUI included with qemu by default?

no. that is the question at hand.

> it's nice to be able to just run qemu ... and have a working framebuffer.

exactly. I actually do that once in a while. I find the GTK interface
pretty nice.

> Alternately, is there some wrapper that is equivalent to that?

Not that I am aware of.

Ideally, the gui should be implemented modular, as a plugin, but when
asking the devs, it will not happen til after SDL2 is fixed.

So for now, we can find/use some wrapper, or have a secondary
package built with --enable-gtk - but that will only be done for x86
and x86_64 not for all 27 archs.

---