Subject: [alpine-devel] xfce 4.12 pushed to edge

From: Natanael Copa <[email-masked]>
Date: Sun, 1 Mar 2015 21:21:50 +0100

Hi,

I just pushed xfce 4.12 to edge.

I am still on vacation so I might be slow to respond to
potensial breakages.

-nc

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Timo Teras <[email-masked]>
Date: Mon, 2 Mar 2015 08:56:56 +0200

On Sun, 1 Mar 2015 21:21:50 +0100

> I am still on vacation so I might be slow to respond to

I cannot upgrade. Not sure if something was recompiled in wrong order,
not recompiled at all; or if apk is having hard time figuring this out.

$ apk upgrade --latest
ERROR: unsatisfiable constraints:
  libxfce4util-4.10.1-r1:
    conflicts: libxfce4util-4.12.0-r0
    breaks: xfce4-4.12.0-r0[libxfce4util>=4.12.0]
    satisfies: xfconf-4.10.0-r1[so:libxfce4util.so.6]
               libxfce4ui-4.10.0-r2[so:libxfce4util.so.6]
               garcon-0.2.1-r1[so:libxfce4util.so.6]
               xfce4-panel-4.10.1-r0[so:libxfce4util.so.6]
               thunar-media-tags-plugin-0.2.1-r0[so:libxfce4util.so.6]
               exo-0.10.2-r2[so:libxfce4util.so.6] thunar-1.6.4-r0[so:libxfce4util.so.6]
  xfconf-4.10.0-r1:
    breaks: xfce4-4.12.0-r0[xfconf>=4.12.0]
    satisfies: libxfce4ui-4.10.0-r2[so:libxfconf-0.so.2]
               xfce4-panel-4.10.1-r0[so:libxfconf-0.so.2]
               xfce4-appfinder-4.12.0-r0[so:libxfconf-0.so.2]
               xfce4-power-manager-1.4.3-r0[so:libxfconf-0.so.2]
               xfce4-session-4.12.0-r0[so:libxfconf-0.so.2]
               xfwm4-4.12.0-r0[so:libxfconf-0.so.2]
               thunar-volman-0.8.1-r0[so:libxfconf-0.so.2]
               xfce4-notifyd-0.2.4-r1[so:libxfconf-0.so.2]
               xfce4-volumed-0.1.13-r1[so:libxfconf-0.so.2]
               xfce4-settings-4.12.0-r0[so:libxfconf-0.so.2]
               xfce4-mixer-4.11.0-r1[so:libxfconf-0.so.2]
               xfdesktop-4.12.0-r0[so:libxfconf-0.so.2] thunar-1.6.4-r0[so:libxfconf-0.so.2]
  libxfce4ui-4.10.0-r2:
    breaks: xfce4-4.12.0-r0[libxfce4ui>=4.12.0]
    satisfies: xfwm4-4.12.0-r0[so:libxfce4kbd-private-2.so.0]
               xfwm4-4.12.0-r0[so:libxfce4ui-1.so.0]
               xfce4-settings-4.12.0-r0[so:libxfce4kbd-private-2.so.0]
               xfce4-settings-4.12.0-r0[so:libxfce4ui-1.so.0]
               xfce4-panel-4.10.1-r0[so:libxfce4ui-1.so.0]
               xfce4-appfinder-4.12.0-r0[so:libxfce4ui-1.so.0]
               xfce4-power-manager-1.4.3-r0[so:libxfce4ui-1.so.0]
               xfce4-session-4.12.0-r0[so:libxfce4ui-1.so.0]
               xfce4-terminal-0.6.3-r1[so:libxfce4ui-1.so.0]
               xfwm4-4.12.0-r0[so:libxfce4kbd-private-2.so.0]
               xfwm4-4.12.0-r0[so:libxfce4ui-1.so.0]
               xfce4-battery-plugin-1.0.5-r2[so:libxfce4ui-1.so.0]
               thunar-volman-0.8.1-r0[so:libxfce4ui-1.so.0]
               xfce4-notifyd-0.2.4-r1[so:libxfce4ui-1.so.0]
               xfburn-0.5.2-r2[so:libxfce4ui-1.so.0]
               xfce4-settings-4.12.0-r0[so:libxfce4kbd-private-2.so.0]
               xfce4-settings-4.12.0-r0[so:libxfce4ui-1.so.0]
               exo-0.10.2-r2[so:libxfce4ui-1.so.0]
               xfce4-mixer-4.11.0-r1[so:libxfce4ui-1.so.0]
               xfdesktop-4.12.0-r0[so:libxfce4ui-1.so.0]
               thunar-1.6.4-r0[so:libxfce4ui-1.so.0]
               xfce4-screenshooter-1.8.2-r1[so:libxfce4ui-1.so.0]
  exo-0.10.2-r2:
    breaks: xfce4-4.12.0-r0[exo>=0.10.3]
    satisfies: xfce4-panel-4.10.1-r0[so:libexo-1.so.0]
               thunar-volman-0.8.1-r0[so:libexo-1.so.0]
               thunar-media-tags-plugin-0.2.1-r0[so:libexo-1.so.0]
               thunar-archive-plugin-0.3.1-r1[so:libexo-1.so.0]
               xfburn-0.5.2-r2[so:libexo-1.so.0] xfce4-settings-4.12.0-r0[so:libexo-1.so.0]
               xfdesktop-4.12.0-r0[so:libexo-1.so.0] thunar-1.6.4-r0[so:libexo-1.so.0]
               xfce4-screenshooter-1.8.2-r1[so:libexo-1.so.0]
  garcon-0.2.1-r1:
    breaks: xfce4-4.12.0-r0[garcon>=0.4.0]
    satisfies: xfce4-panel-4.10.1-r0[so:libgarcon-1.so.0]
               xfce4-appfinder-4.12.0-r0[so:libgarcon-1.so.0]
               xfce4-settings-4.12.0-r0[so:libgarcon-1.so.0]
               xfdesktop-4.12.0-r0[so:libgarcon-1.so.0]
  xfce4-panel-4.10.1-r0:
    breaks: xfce4-4.12.0-r0[xfce4-panel>=4.12.0]
    satisfies: xfce4-power-manager-1.4.3-r0[so:libxfce4panel-1.0.so.4]
               xfce4-battery-plugin-1.0.5-r2[so:libxfce4panel-1.0.so.4]
               xfce4-mixer-4.11.0-r1[so:libxfce4panel-1.0.so.4]
               thunar-1.6.4-r0[so:libxfce4panel-1.0.so.4]
               xfce4-screenshooter-1.8.2-r1[so:libxfce4panel-1.0.so.4]
  thunar-1.6.4-r0:
    breaks: xfce4-4.12.0-r0[thunar>=1.6.6]
    satisfies: thunar-media-tags-plugin-0.2.1-r0[so:libthunarx-2.so.0]
               thunar-archive-plugin-0.3.1-r1[so:libthunarx-2.so.0]
               xfdesktop-4.12.0-r0[so:libthunarx-2.so.0]
  libxfce4util-4.12.0-r0:
    conflicts: libxfce4util-4.10.1-r1
    satisfies: xfce4-4.12.0-r0[libxfce4util>=4.12.0]
               thunar-volman-0.8.1-r0[so:libxfce4util.so.7]
               xfce4-battery-plugin-1.0.5-r2[so:libxfce4util.so.7]
               xfce4-screenshooter-1.8.2-r1[so:libxfce4util.so.7]
               xfce4-terminal-0.6.3-r1[so:libxfce4util.so.7]
               xfwm4-4.12.0-r0[so:libxfce4util.so.7]
               thunar-archive-plugin-0.3.1-r1[so:libxfce4util.so.7]
               xfce4-settings-4.12.0-r0[so:libxfce4util.so.7]
               xfburn-0.5.2-r2[so:libxfce4util.so.7]
               xfce4-power-manager-1.4.3-r0[so:libxfce4util.so.7]
               xfce4-appfinder-4.12.0-r0[so:libxfce4util.so.7]
               xfce4-mixer-4.11.0-r1[so:libxfce4util.so.7]
               xfdesktop-4.12.0-r0[so:libxfce4util.so.7]
               xfce4-session-4.12.0-r0[so:libxfce4util.so.7]
               xfce4-notifyd-0.2.4-r1[so:libxfce4util.so.7]

---

---

From: Timo Teras <[email-masked]>
Date: Mon, 2 Mar 2015 14:06:15 +0200

On Mon, 2 Mar 2015 08:56:56 +0200

> not recompiled at all; or if apk is having hard time figuring this

Figured this out. testing/thunar-media-tags-plugin which I had
installed required a recompile. Now it installed and seems to be ok.

Though, "Applications -> About Xfce" reports version 4.10 still for
some reason. But I can verify that 4.12 is indeed installed.

---

---

From: Natanael Copa <[email-masked]>
Date: Tue, 3 Mar 2015 15:48:09 +0100

On Mon, 2 Mar 2015 14:06:15 +0200

> > not recompiled at all; or if apk is having hard time figuring this

I think xfce4-notes-plugin can cause something similar. The latest
release still depends on the deprecated libxfcegui4.

https://bugzilla.xfce.org/show_bug.cgi?id=11623
 
> some reason. But I can verify that 4.12 is indeed installed.

looks like that was fixed with libxfce4util-4.12.1

thanks!

-nc

---