Subject: [alpine-devel] Alpine 3.2.0 rc2 released

From: Natanael Copa <[email-masked]>
Date: Thu, 7 May 2015 22:07:31 +0200

Hi,

Alpine 3.2.0 rc2 is released.

Notable changes since rc1:
- 3.18.13-grsec kernel
- setup-interfaces fixed

As mentioned earlier, it would be nice if we could have full focus on
fixing known issues and testing.

Thanks!

-nc

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Jeff Pohlmeyer <[email-masked]>
Date: Mon, 11 May 2015 21:51:36 -0500

( Sorry if you get this twice, I think I forgot to "reply to all" )

I haven't had a chance to try the RC but the last time I checked, the
xf86-video-vesa and xf86-video-fbdev drivers would not work for me in edge:

fbdev:
  Assertion failed: key->initialized (../include/privates.h:
dixGetPrivateAddr: 122)

vesa:
  (EE) VESA(0): Cannot read int vect

Has anyone tried these lately?

---

---

From: Jeff Bilyk <[email-masked]>
Date: Thu, 7 May 2015 16:56:35 -0400

Not sure if this is a regression or known bug, but on a fresh rc2 system, I
cannot install a locally compiled package that's not signed using the
alpine keys.  If I try to add with just apk add <filename>.apk, I get
(expected behaviour):

ERROR: You tried to add a non-repository package to system, but it would be
lost on next reboot. Enable package caching (apk cache --help) or use
--force if you know what you are doing.

If I use apk add <filename>.apk --force, I receive (expected error):

ERROR: /media/usb/bsn-setup-9.36-r0.apk: UNTRUSTED signature

If I also use the --allow-untrusted flag:

(none):~# apk add /media/usb/setup-9.36-r0.apk --force --allow-untrusted
OK: 6 MiB in 16 packages

That results in no files installed to the system.  The package contents are
a few bash scripts to set up an LXC host and configure the system.

In an unrelated bug, seems like the syslog service is stopped on boot with
rc2.

-- 
Jeff

---

From: Timo Teras <[email-masked]>
Date: Fri, 8 May 2015 07:58:37 +0300

Hi,

Sounds like http://bugs.alpinelinux.org/issues/4064

On Thu, 7 May 2015 16:56:35 -0400
Jeff Bilyk <[email-masked]> wrote:

> Not sure if this is a regression or known bug, but on a fresh rc2
> system, I cannot install a locally compiled package that's not signed
> using the alpine keys.  If I try to add with just apk add
> <filename>.apk, I get (expected behaviour):
> 
> ERROR: You tried to add a non-repository package to system, but it
> would be lost on next reboot. Enable package caching (apk cache
> --help) or use --force if you know what you are doing.
> 
> (none):~# apk add /media/usb/setup-9.36-r0.apk --force
> --allow-untrusted OK: 6 MiB in 16 packages
> 
> That results in no files installed to the system.  The package
> contents are a few bash scripts to set up an LXC host and configure
> the system.
> 
> In an unrelated bug, seems like the syslog service is stopped on boot
> with rc2.
> 
> 
> > As mentioned earlier, it would be nice if we could have full focus
> > on fixing known issues and testing.
> >
> > Thanks!
> >
> > -nc
> >
> >
> > ---

---

---

From: Jeff Bilyk <[email-masked]>
Date: Fri, 8 May 2015 08:43:03 -0400

> Sounds like http://bugs.alpinelinux.org/issues/4064

In the case of the package I'm trying to install, it does depend on lua
(which I had forgotten about), which isn't available in the rc2 iso, but is
from the full iso.  If the same process is tried from a full edge iso with
the latest version of apk-tools, the install should work?

-- 
Jeff

---

From: Jeff Bilyk <[email-masked]>
Date: Fri, 8 May 2015 09:21:08 -0400

> the latest version of apk-tools, the install should work?

Answered my own question by creating a new full edge iso and tested this.
Once lua is in the iso's apk folder, then this works.

-- 
Jeff

---

From: Natanael Copa <[email-masked]>
Date: Fri, 8 May 2015 10:47:58 +0200

> In an unrelated bug, seems like the syslog service is stopped on boot with

And hostname is not set to localhost but to '(none)'. It seems that the
'boot' runlevel is not pulled in when switching to 'default'.

I wonder if this is a bug or new feature in openrc...

-nc

---

---

From: Leonardo Arena <[email-masked]>
Date: Thu, 14 May 2015 10:19:24 +0200

> Alpine 3.2.0 rc2 is released.
I've upgraded a DELL Latitude E5510 from 3.1. Udev did not startup
automatically after upgrade, but everything else looks to work just fine.

Thanks!

---

From: Natanael Copa <[email-masked]>
Date: Fri, 15 May 2015 13:50:14 +0200

On Thu, 14 May 2015 10:19:24 +0200

> automatically after upgrade, but everything else looks to work just fine.

It might be related this:
https://github.com/OpenRC/openrc/issues/54

which will be fixed in rc3.

-nc

---