Subject: [alpine-devel] [PATCH] build xorg-server without dbus

From: Szabolcs Nagy <[email-masked]>
Date: Sun, 24 May 2015 17:41:56 +0200

dbus seems to be an accidental build dependency of
xorg-server

if systemd-logind support is not explicitly disabled
and dbus is available then xorg will enable logind
support and dbus

this causes a useless connection to the dbus system
bus on xorg startup (only hal and logind would use it)
and if there is no dbus running on the system then
the Xorg.log gets filled with

 (EE) dbus-core: error connecting to system bus: org.freedesktop.DBus.Error.FileNotFound (Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory)

every 10 seconds..

so i rebuilt my xorg-server package with the attached
patch
diff --git a/main/xorg-server/APKBUILD b/main/xorg-server/APKBUILD
index 9d86472..8cf3198 100644
--- a/main/xorg-server/APKBUILD
+++ b/main/xorg-server/APKBUILD
@@ -18,7 +18,6 @@ depends="
 	xkeyboard-config
 	xkbcomp
 	xinit
-	dbus-x11
 	"
 depends_dev="
 	bigreqsproto
@@ -51,7 +50,6 @@ makedepends="
 	$depends_dev
 	autoconf
 	automake
-	dbus-dev
 	libdrm-dev
 	libtool
 	libx11-dev
@@ -134,6 +132,7 @@ build() {
 		--enable-xephyr \
 		--disable-config-hal \
 		--disable-dmx \
+		--disable-systemd-logind \
 		--disable-tslib \
 		--enable-config-udev \
 		|| return 1

---

From: Szabolcs Nagy <[email-masked]>
Date: Mon, 3 Aug 2015 15:27:13 +0200

> so i rebuilt my xorg-server package with the attached

ping

i've seen other ppl running into this.

i think there is no loss of functionality without dbus.

> +		--disable-systemd-logind \

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Natanael Copa <[email-masked]>
Date: Mon, 3 Aug 2015 16:09:48 +0200

On Mon, 3 Aug 2015 15:27:13 +0200

> > so i rebuilt my xorg-server package with the attached

Sorry. I thought this was applied already.

> i think there is no loss of functionality without dbus.

commit e407b99757d2de626285db2da8692c7c883d6436 (Sun May 24 17:58:47
2015 -0400, main/xorg-xserver: disable systemd features) should disable
systemd already.

I have applied the removal of dbus-dev and dbus-x11 deps now. Thanks

-nc

---