Subject: [alpine-devel] Best place to send howtos?

From: Isaac Dunham <[email-masked]>
Date: Thu, 24 Sep 2015 21:08:41 -0700

Hello,
I've configured an Alpine Linux system as a wireless router.
The approach I followed is rather different from what the wiki page [0]
seems to be meant for, and I also notice that the wiki page is marked
as a work-in-progress.

I've written up the steps that it took to make it consistently
reproducible (as in "comes back up on boot"), with a bit of comments on
the config files involved; this might make a decent HOWTO/wiki guide.
Is the wiki the only place for such things?
(If so, could someone else post it there, or should I ask for access?)

The basis for what I did is the RPI-Wireless-Hotspot page [1];
I've adjusted it to fit Alpine better.
A quick overview of what I did:
- add iptables, udhcpd, and hostapd
- configure hostapd
- configure udhcpd
- configure iptables for NAT/masquerading
- configure the wireless card, and make it all start in proper order

[0] http://wiki.alpinelinux.org/wiki/How_to_setup_a_wireless_access_point
[1] http://elinux.org/RPI-Wireless-Hotspot
Side notes:
- udhcpd works right, it seems
- it would be nice to see ACS (Automatic Channel Selection) enabled in
 hostapd, though not necessarily enabled in the config file by default.
- for reasons unknown to me, if I configure iptables masquerading to
 forward packets from wlan0, it results in ifup claiming that wlan0
 is already up
- for reasons unknown to me, the code in the iptables init script that's
 supposed to enable forwarding seems not to do so.

Thanks,
Isaac Dunham

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: [email-masked]
Date: Wed, 30 Sep 2015 21:46:58 -0700

> [1] http://elinux.org/RPI-Wireless-Hotspot

Now posted at:
http://wiki.alpinelinux.org/wiki/Wireless_AP_with_udhcpd_and_NAT

Thanks,
Isaac Dunham

---