Subject: Re: [alpine-devel] alsamixer and mpv are broken in latest release + quetion

From: Isaac Dunham <[email-masked]>
Date: Thu, 19 Nov 2015 18:09:50 -0800

(Please don't post to the list in HTML, it makes it quite hard to read.)

On Sat, Nov 14, 2015 at 11:06:11PM +0100, Christie Taylor wrote:
> After upgrading to v3.3 repo:
> 
> 1) mpv has permissions problems, has to be run with sudo. libGL error: failed to open drm device: Permission denied

ls -l /dev/dri/
?

I think this should be chown root:video, chmod ug=rw or similar.
(Right here, it's screwing up such that it's root:root. I've not poked at it.)
> 2) [snip]

> Also a question:
> 
> 3) I thought v3.3 would get rid of udev and use mdev from gentoo, but I still get udev messages on boot?

Alpine Linux has used mdev (which is from *busybox*, not gentoo) for quite
a while. Adding Xorg the usual way (setup-xorg) pulls in udev; it's
*possible* to install X and use mdev, if you add the right config files
(eg, from mdev-like-a-boss).
Recently, Alpine switched from old udev to eudev (a gentoo project); this
only affects systems with udev installed.

If you want to use mdev instead of udev, I think this is what I did.

- disable any X display manager or autostart script, since you could end up
breaking X.

-git clone git://github.com/slashbeast/mdev-like-a-boss, then read the notes.
-add xf86-input-keyboard, xf86-input-mouse, and (for laptops)
xf86-input-synaptics.
-copy xorg.conf.d/* to /etc/xorg.conf.d/

-make sure you have acpid enabled:
rc-update |grep acpid
#if it's not enabled:
rc-update add acpid
(this is so you can shut down cleanly if you break stuff)

- Restart, check that X works:
startx

- exit X
- disable udev, mount a tmpfs filesystem over /dev, and test mdev:
service udev stop
mount -t tmpfs mdev /dev
service mdev start

- check that X works (if you copied the config files and added the drivers,
it *should be* fine)

- disable udev/eudev, enable mdev and hwdrivers:

rc-update del eudev || rc-update del udev
rc-update add mdev ; rc-update add hwdrivers

- Restart, check that X works.

- Re-enable your X autostart script/display manager of choice.

Most of that is safety checking, so you won't accidentally lock yourself
out.

HTH,
Isaac Dunham

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: "Christie Taylor" <[email-masked]>
Date: Sat, 21 Nov 2015 13:54:20 +0100

Sorry, now I use only plaintext email. Thanks for the tip.
mpv works now after update, alsamixer still segfault on alpine v3.3
Thanks for explaining mdev, but I think BusyBox is too big and tries to bite more than can chew, with a single binary having all those things: coreutilities, dhcp server, device manager, etc. Sounds bad to me.

I found smdev, that's like mdev but simpler, cleaner and on-its-own, doesn't come in huge BusyBox package.
What do you think of it?

Thanks.

> Sent: Friday, November 20, 2015 at 12:09 AM
> From: "Isaac Dunham" <[email-masked]>
> To: "Christie Taylor" <[email-masked]>
> Cc: [email-masked]
> Subject: Re: [alpine-devel] alsamixer and mpv are broken in latest release + quetion
>
> 

---