Subject: [alpine-devel] New orphaned packages in main/ and community/

From: Sören Tempel <[email-masked]>
Date: Wed, 1 Nov 2017 16:56:51 +0100

Hello there,

I just pushed two commits to the aports repository which removed Peter
Bui and Eivind Uggedal as maintainers from all packages. This change has
been made since these two haven't been active since 2015. However, since
they also maintained packages in main/ and community/ these packages no
longer have a maintainer and desperately need one.

The following packages are affected:

community/ncmpc/APKBUILD
main/abcde/APKBUILD
main/acpi/APKBUILD
main/cd-discid/APKBUILD
main/gcalcli/APKBUILD
main/offlineimap/APKBUILD
main/py-asn1-modules/APKBUILD
main/py-backports_abc/APKBUILD
main/py-certifi/APKBUILD
main/py-exifread/APKBUILD
main/py-eyed3/APKBUILD
main/py-gflags/APKBUILD
main/py-google-api-python-client/APKBUILD
main/py-icu/APKBUILD
main/py-meld3/APKBUILD
main/py-oauth2client/APKBUILD
main/py-requests-oauthlib/APKBUILD
main/py-rsa/APKBUILD
main/py-tornado/APKBUILD
main/py-twitter/APKBUILD
main/py-vobject/APKBUILD
main/py2-backports.ssl_match_hostname/APKBUILD
main/py2-singledispatch/APKBUILD
main/supervisor/APKBUILD
community/go/APKBUILD
community/obnam/APKBUILD
main/bash-completion/APKBUILD
main/dzen/APKBUILD
main/fcgiwrap/APKBUILD
main/ghi/APKBUILD
main/herbstluftwm/APKBUILD
main/hiredis/APKBUILD
main/powertop/APKBUILD
main/py-cliapp/APKBUILD
main/py-flask-assets/APKBUILD
main/py-flask-oauthlib/APKBUILD
main/py-flask-script/APKBUILD
main/py-flask/APKBUILD
main/py-hiredis/APKBUILD
main/py-hoedown/APKBUILD
main/py-itsdangerous/APKBUILD
main/py-jwt/APKBUILD
main/py-larch/APKBUILD
main/py-nose/APKBUILD
main/py-oauthlib/APKBUILD
main/py-redis/APKBUILD
main/py-tracing/APKBUILD
main/py-ttystatus/APKBUILD
main/py-urlnorm/APKBUILD
main/py-webassets/APKBUILD
main/py-werkzeug/APKBUILD
main/redis/APKBUILD
main/spawn-fcgi/APKBUILD
main/tarsnap/APKBUILD

If anyone uses any of those packages on a regular basis then please take
over maintainership for them. Keep in mind that there are additional
packages in communtiy/ and main/ that currently don't have a maintainer.
According to:

	grep -l -r '^# Maintainer:$' community/ main/ | wc -l

We have 121 orphaned packages in those repositories. It would be nice if
that number could be significantly reduced until the next release.
Either by moving packages back to testing or by finding new maintainers
for them.

Cheers,
Sören

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Cág <[email-masked]>
Date: Wed, 1 Nov 2017 16:57:36 +0000

> Hello there,

Hello,

> longer have a maintainer and desperately need one.

I think I can grab main/acpi and main/dzen and maybe something from this

`grep -l -r '^# Maintainer:$' community/ main/`

list. Both of them have "|| return 1" in either build() or package(),
I assume this is no longer needed? If it is so, I will send patches.

Thanks 

-- 
caóc

---

---

From: William Pitcock <[email-masked]>
Date: Wed, 1 Nov 2017 12:29:55 -0500

Hi,

> I assume this is no longer needed? If it is so, I will send patches.

Indeed, those return statements are no longer needed.

William

---

---

From: Cág <[email-masked]>
Date: Wed, 1 Nov 2017 18:05:15 +0000

> Indeed, those return statements are no longer needed.

OK, thanks. Another question: at patchwork dot alpinelinux dot org there are
currently a few patches pending, some of them apparently aren't applicable but
others like mawk, nawk, s-nail, and especially texmf-dist are interesting.
What is the procedure of reviewing them? texmf-dist is from August, and I think
it is an important one because it brings LaTeX to Alpine.

Cheers

-- 
caóc

---

---

From: Jean-Louis Fuchs <[email-masked]>
Date: Thu, 2 Nov 2017 11:00:54 +0100

Hi

> main/py-tornado/APKBUILD

I could take some of the important python packages. But someone has to
commit them, currently I have 1 1/2 month old open patches on
patchwork. It seems that there is no commiter assigned to python
stuff.

Best,
    Jean-Louis