Subject: [alpine-devel] Alpine Linux 3.7.0 Release Candidate 1 is out

From: Natanael Copa <[email-masked]>
Date: Thu, 23 Nov 2017 22:40:46 +0100

Hi!

I am pleased to announce the first release candidate of Alpine Linux
3.7.0.

The big news is that is now support UEFI.

Would be nice to have some help with testing all the different release
variants and architectures.

Thanks!

-nc

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: "x9p" <[email-masked]>
Date: Sat, 25 Nov 2017 11:17:55 -0200

Thank you for the hard work and the release.

x9p

---

---

From: "x9p" <[email-masked]>
Date: Sat, 25 Nov 2017 18:06:31 -0200

could not find the link of rc-1 to test.

cheers.

x9p

---

---

From: "A. Wilcox" <[email-masked]>
Date: Sat, 25 Nov 2017 14:20:24 -0600

> could not find the link of rc-1 to test.

They can be found at:

https://nl.alpinelinux.org/alpine/v3.7/releases/

or your favourite Alpine mirror..

- --arw

- -- 
A. Wilcox (awilfox)
Project Lead, Adélie Linux
http://adelielinux.org

---

---

From: Jack Schmidt <[email-masked]>
Date: Sat, 25 Nov 2017 21:39:02 -0500

Here are my notes on Alpine 3.7.0 rc1 installations using VirtualBox hosted on x86_64 Darwin.

Summary:

* Standard, Extended, Vanilla, Virtual on BIOS just work (minor issues)
* Standard, Extended, Vanilla on EFI has one major issue (bad fsck)
* Virtual is broken on EFI (no kernel support)

In each case I tried to do a base install to an IDE disk, as "sys", default options. I also tried booting the ISO as a run-from-ram system. Virtual on EFI requires a serial console, but otherwise all ISOs run-from-ram smoothly.

The fsck issue needs to be fixed. The 4.9.63 vs 4.9.59 should be fixed. The Virtual EFI probably should be fixed, but is easily worked-around by end users. The minor issues would be nice to increase adoption of bootable alpine, but aren't necessary. I assume docker containers are just fine: I use edge all the time without trouble.

Standard, Extended, Vanilla, Virtual legacy BIOS minor issues:

* Install boot might be too quiet for too long

The BIOS boot takes 5 to 20 seconds, so the "quiet" option in boot/syslinux/syslinux.cfg might need to be accompanied by a "say" or a "menu autoboot" type thing. Grub EFI boot is mostly better, but sometimes takes a long time between messages. The installed version is a little slow, but has a reasonable amount of messages to let you know it is progressing.

Standard, Extended, Vanilla, Virtual both BIOS and EFI minor issues:

* After setup-alpine is complete, eject cdrom
* Install boot and installed root use different kernels, rescue is hard
* (hardened/virthardened) Guest additions kernel version problem

Install for BIOS works easily on Standard, Extended, Vanilla, Virtual. Install for EFI works easily on Standard, Extended, Vanilla, but fails for Virtual.

After the install, setup-alpine asks to reboot, but doesn't "eject -s" (-s required for me) the cd. That means alpine reboots under the readonly cdrom with a tmpfs. This works fine, but is surprising if you are installing software.

After the eject, system comes up much more noisily / green, so probably reassuring.

However, it comes up under 4.9.59-0-*hardened or 4.9.65 vanilla, so one can't use the ISO's 4.9.63 kernel to boot a rescue. If it isn't too much trouble, for the final 3.7 release, it'd be good if the kernel matched on the ISO's boot and the ISO's apk.

Guest additions (mostly not needed by me) are hard to load, since they are in /lib/modules/4.9.65-* but the kernel is actually 4.9.59-*. Once that is fixed, all good.

Standard, Extended, Vanilla EFI issue (vfat.fsck)

* 1.5GB disk required
* vfat.fsck

Alpine is known for it's very small size. The ISOs are a nice size. I have a VM that runs off a 10MB iso, and the Virtual ISO is good at under 40MB. I was trying out ubuntu variations and had to choose my physical network to handle the each-iso-is-a-gig downloads. Alpine is very easy to try. However, the new EFI install creates a 500MB /boot/efi partition to hold 500KB of boot data. It might be worthwhile to check the total size of the disk, and not use so much on it for smaller (1 or 2 gig) drives.

More importantly /boot/efi fails its fsck due to a syntax error:

fsck.vfat: unrecognized option: C

This is from /etc/init.d/fsck. Since the fsck service fails, most of the rest of the boot is not really attempted. / is mounted read-only. Network is down.

Remounting / rw, removing the -C0 from fsck, and rebooting is OK. You still get a scary error, but the system comes up fine.

See also https://bugs.alpinelinux.org/issues/8090 for raspberry pi breakage and suggested fix (seems reasonable to me: write a simple shell script wrapper for fsck.vfat and fsck.fat that ignores ext2/3/4 arguments).

I think this must be fixed before a release.

Virtual EFI fail

Virtual's virthardened kernel lacks EFI support (even in module form). Also it is worse on VirtualBox EFI since it also lacks video drivers. The serial console works, but is hard to use (telnet lacks tab-completion, GNU screen requires socat, and only one terminal). Since /sys/firmware/efi is not available, setup-disk does not realize it was an EFI boot and does everything wrong.

I suspect it would be a good idea to include EFI support for the Virtual ISO / virthardened kernel too. The fix would make Alpine seem more reliable and would cut down on the "why is the screen black?" questions. However, to workaround it is easy to turn off EFI, and legacy BIOS is more standard for virtual machines, I believe.

---

---

From: Natanael Copa <[email-masked]>
Date: Wed, 29 Nov 2017 18:14:04 +0100

Hi,

Thanks you very much for testing.

I think the most critical issues are fixed. I have not bothered fix the
eject issue, since I think it mostly affects virtualbox only.

I haven't looked at the alpine-virt + efi issue, yet. I suppose there
are some kernel modules that are needed?

Can you please re-run the tests with the 3.7.0_rc3?

Thanks!

-nc

On Sat, 25 Nov 2017 21:39:02 -0500

---

---

From: Gennady Feldman <[email-masked]>
Date: Thu, 30 Nov 2017 09:50:20 -0500

Hi,

>From a quick look looks like:
CONFIG_EFI=y
CONFIG_EFI_STUB=y

are missing from the virthardened config.

Thank you,

On Wed, Nov 29, 2017 at 12:14 PM, Natanael Copa <[email-masked]>
wrote:

> > In each case I tried to do a base install to an IDE disk, as "sys",
> default options. I also tried booting the ISO as a run-from-ram system.
> Virtual on EFI requires a serial console, but otherwise all ISOs
> run-from-ram smoothly.
> >
> > The fsck issue needs to be fixed. The 4.9.63 vs 4.9.59 should be fixed.
> The Virtual EFI probably should be fixed, but is easily worked-around by
> end users. The minor issues would be nice to increase adoption of bootable
> alpine, but aren't necessary. I assume docker containers are just fine: I
> use edge all the time without trouble.
> >
> >
> > The BIOS boot takes 5 to 20 seconds, so the "quiet" option in
> boot/syslinux/syslinux.cfg might need to be accompanied by a "say" or a
> "menu autoboot" type thing. Grub EFI boot is mostly better, but sometimes
> takes a long time between messages. The installed version is a little slow,
> but has a reasonable amount of messages to let you know it is progressing.
> >
> >
> > Install for BIOS works easily on Standard, Extended, Vanilla, Virtual.
> Install for EFI works easily on Standard, Extended, Vanilla, but fails for
> Virtual.
> >
> > After the install, setup-alpine asks to reboot, but doesn't "eject -s"
> (-s required for me) the cd. That means alpine reboots under the readonly
> cdrom with a tmpfs. This works fine, but is surprising if you are
> installing software.
> >
> > However, it comes up under 4.9.59-0-*hardened or 4.9.65 vanilla, so one
> can't use the ISO's 4.9.63 kernel to boot a rescue. If it isn't too much
> trouble, for the final 3.7 release, it'd be good if the kernel matched on
> the ISO's boot and the ISO's apk.
> >
> > Guest additions (mostly not needed by me) are hard to load, since they
> are in /lib/modules/4.9.65-* but the kernel is actually 4.9.59-*. Once that
> is fixed, all good.
> >
> >
> > Alpine is known for it's very small size. The ISOs are a nice size. I
> have a VM that runs off a 10MB iso, and the Virtual ISO is good at under
> 40MB. I was trying out ubuntu variations and had to choose my physical
> network to handle the each-iso-is-a-gig downloads. Alpine is very easy to
> try. However, the new EFI install creates a 500MB /boot/efi partition to
> hold 500KB of boot data. It might be worthwhile to check the total size of
> the disk, and not use so much on it for smaller (1 or 2 gig) drives.
> >
> > This is from /etc/init.d/fsck. Since the fsck service fails, most of the
> rest of the boot is not really attempted. / is mounted read-only. Network
> is down.
> >
> > Remounting / rw, removing the -C0 from fsck, and rebooting is OK. You
> still get a scary error, but the system comes up fine.
> >
> > See also https://bugs.alpinelinux.org/issues/8090 for raspberry pi
> breakage and suggested fix (seems reasonable to me: write a simple shell
> script wrapper for fsck.vfat and fsck.fat that ignores ext2/3/4 arguments).
> >
> > Virtual's virthardened kernel lacks EFI support (even in module form).
> Also it is worse on VirtualBox EFI since it also lacks video drivers. The
> serial console works, but is hard to use (telnet lacks tab-completion, GNU
> screen requires socat, and only one terminal). Since /sys/firmware/efi is
> not available, setup-disk does not realize it was an EFI boot and does
> everything wrong.
> >
> > I suspect it would be a good idea to include EFI support for the Virtual
> ISO / virthardened kernel too. The fix would make Alpine seem more reliable
> and would cut down on the "why is the screen black?" questions. However, to
> workaround it is easy to turn off EFI, and legacy BIOS is more standard for
> virtual machines, I believe.
> >
> >
> >
> > ---

---

From: Jakub Jirutka <[email-masked]>
Date: Thu, 30 Nov 2017 15:52:45 +0100

Wait, VirtualBox *requires* EFI now? If not, why to enable it in kernel for VMs?

Jakub

> On 30. Nov 2017, at 15:50, Gennady Feldman <[email-masked]> wrote:
> 
> Hi,
> 
> On Wed, Nov 29, 2017 at 12:14 PM, Natanael Copa <[email-masked] <mailto:[email-masked]>> wrote:
> Hi,
> 
> Jack Schmidt <[email-masked] <mailto:[email-masked]>> wrote:
> 
> > See also https://bugs.alpinelinux.org/issues/8090 <https://bugs.alpinelinux.org/issues/8090> for raspberry pi breakage and suggested fix (seems reasonable to me: write a simple shell script wrapper for fsck.vfat and fsck.fat that ignores ext2/3/4 arguments).
> >
> > Unsubscribe:  [email-masked] <mailto:[email-masked]>
> > Help:         [email-masked] <mailto:[email-masked]>
> > ---
> >
> 
> 
> 
> ---
> Unsubscribe:  [email-masked] <mailto:[email-masked]>
> Help:         [email-masked] <mailto:[email-masked]>
> ---
> 
>

---

From: Gennady Feldman <[email-masked]>
Date: Thu, 30 Nov 2017 19:50:49 -0500

HI Jakub,

I am going to answer what I know ( I am sure others will have their own
reasons). I have Virtualbox 5.1.30 (there's also 5.2.x out) installed on
Windows 7.
Right now from what I can see it's NOT a requirement, but the option is
there.

I did download and try to play a bit with the 3.7rc3 both virt and
standard. Virt doesn't even boot. Standard seems to be fine as long as I
don't install the virt kernel and try to boot with it.

>From what I read EFI seems like the replacement for BIOS and should provide
a number of benefits including a better/bigger console (which I like quite
a bit, kinda hate doing console installs
using legacy BIOS inside VirtualBox) and faster boot time among other
things. I might even convert my Alpine VMs to use it once virt kernel
supports it.

I guess from MBR <=> GPT perspective it could go either way. Things might
get interesting with bigger external volumes, but not for something I am
working/messing with right now.

setup-disk does some interesting stuff in EFI mode:
- boot has hard-coded 512 (which seems quite high?)
- creates a swap partition (2G for me). I would love to turn that off if I
am running inside VirtualBox or being able to choose.

I also wanted to ask if it would make sense to have "setup-virtualbox"
script that would install virtualbox packages and tweak some things for VMs
running inside VirtualBox.

Thank you,

Gennady

On Thu, Nov 30, 2017 at 9:52 AM, Jakub Jirutka <[email-masked]> wrote:

>> > This is from /etc/init.d/fsck. Since the fsck service fails, most of
>> the rest of the boot is not really attempted. / is mounted read-only.
>> Network is down.
>> >
>> > I suspect it would be a good idea to include EFI support for the
>> Virtual ISO / virthardened kernel too. The fix would make Alpine seem more
>> reliable and would cut down on the "why is the screen black?" questions.
>> However, to workaround it is easy to turn off EFI, and legacy BIOS is more
>> standard for virtual machines, I believe.
>> >
>> >
>> >
>> > ---

---

From: Gennady Feldman <[email-masked]>
Date: Fri, 1 Dec 2017 10:10:04 -0500

Hi Jakub,

Was thinking a bit more about virt + EFI.. Any reason you are against
enabling it? It looks like various VM platforms have already added or are
adding EFI support to replace "legacy BIOS" as part of the VM environment.

Right now that kernel doesn't boot and from the looks of it it's only
enabling 2 modules.

P.S. Can somebody bump community/virtualbox-guest-additions/APKBUILD 5.1.26
=> 5.1.30?

Thank you,

Gennady

On Thu, Nov 30, 2017 at 7:50 PM, Gennady Feldman <[email-masked]> wrote:

> From what I read EFI seems like the replacement for BIOS and should
> provide a number of benefits including a better/bigger console (which I
> like quite a bit, kinda hate doing console installs
>>> > The fsck issue needs to be fixed. The 4.9.63 vs 4.9.59 should be
>>> fixed. The Virtual EFI probably should be fixed, but is easily
>>> worked-around by end users. The minor issues would be nice to increase
>>> adoption of bootable alpine, but aren't necessary. I assume docker
>>> containers are just fine: I use edge all the time without trouble.
>>> >
>>> >
>>> > However, it comes up under 4.9.59-0-*hardened or 4.9.65 vanilla, so
>>> one can't use the ISO's 4.9.63 kernel to boot a rescue. If it isn't too
>>> much trouble, for the final 3.7 release, it'd be good if the kernel matched
>>> on the ISO's boot and the ISO's apk.
>>> >

---

From: Natanael Copa <[email-masked]>
Date: Fri, 1 Dec 2017 17:37:56 +0100

On Fri, 1 Dec 2017 10:10:04 -0500
 
> P.S. Can somebody bump community/virtualbox-guest-additions/APKBUILD 5.1.26

done. Thanks!

-nc

---

---

From: Jakub Jirutka <[email-masked]>
Date: Fri, 1 Dec 2017 17:44:18 +0100

Hi Gennady,

> Any reason you are against enabling it?

I’m not strongly against it, I just prefer to keep number of enabled features at minimum (and yes, I know that the current configs are exactly opposite). I don’t see any added value of EFI for VMs. Actually I can hardly see it even for physical HW, it just allowed vendors to add more crap and bloat into it, but that’s a different story.

It other devs don’t mind adding these features, let’s do it.

Jakub

> On 1. Dec 2017, at 16:10, Gennady Feldman <[email-masked]> wrote:
> 
> Hi Jakub,
> 
> Was thinking a bit more about virt + EFI.. Any reason you are against enabling it? It looks like various VM platforms have already added or are adding EFI support to replace "legacy BIOS" as part of the VM environment.
> 
> Right now that kernel doesn't boot and from the looks of it it's only enabling 2 modules.
> 
> P.S. Can somebody bump community/virtualbox-guest-additions/APKBUILD 5.1.26 => 5.1.30?
> 
> Thank you,
> 
> Gennady
> 
> On Thu, Nov 30, 2017 at 7:50 PM, Gennady Feldman <[email-masked] <mailto:[email-masked]>> wrote:
> HI Jakub,
> 
> I am going to answer what I know ( I am sure others will have their own reasons). I have Virtualbox 5.1.30 (there's also 5.2.x out) installed on Windows 7. 
> Right now from what I can see it's NOT a requirement, but the option is there. 
> 
> I did download and try to play a bit with the 3.7rc3 both virt and standard. Virt doesn't even boot. Standard seems to be fine as long as I don't install the virt kernel and try to boot with it.
> 
> From what I read EFI seems like the replacement for BIOS and should provide a number of benefits including a better/bigger console (which I like quite a bit, kinda hate doing console installs
> using legacy BIOS inside VirtualBox) and faster boot time among other things. I might even convert my Alpine VMs to use it once virt kernel supports it.
> 
> I guess from MBR <=> GPT perspective it could go either way. Things might get interesting with bigger external volumes, but not for something I am working/messing with right now.
> 
> - creates a swap partition (2G for me). I would love to turn that off if I am running inside VirtualBox or being able to choose.
> 
> I also wanted to ask if it would make sense to have "setup-virtualbox" script that would install virtualbox packages and tweak some things for VMs
> On Thu, Nov 30, 2017 at 9:52 AM, Jakub Jirutka <[email-masked] <mailto:[email-masked]>> wrote:
>> On 30. Nov 2017, at 15:50, Gennady Feldman <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Hi,
>>

---

From: Kiyoshi Aman <[email-masked]>
Date: Fri, 01 Dec 2017 16:49:24 +0000

I have hardware which will not boot in 'legacy BIOS' mode at all (Atom
x5-Z8330-based Intel compute stick), and while VMs don't necessarily need
to emulate that, it can be helpful to force EFI-only boot for debugging
purposes.

On Fri, Dec 1, 2017 at 10:44 AM Jakub Jirutka <[email-masked]> wrote:

> I’m not strongly against it, I just prefer to keep number of enabled
> features at minimum (and yes, I know that the current configs are exactly
> opposite). I don’t see any added value of EFI for VMs. Actually I can
> hardly see it even for physical HW, it just allowed vendors to add more
> crap and bloat into it, but that’s a different story.
>
>> - creates a swap partition (2G for me). I would love to turn that off if
>> I am running inside VirtualBox or being able to choose.
>>
>>>> > Install for BIOS works easily on Standard, Extended, Vanilla,
>>>> Virtual. Install for EFI works easily on Standard, Extended, Vanilla, but
>>>> fails for Virtual.
>>>> >
>>>> > After the install, setup-alpine asks to reboot, but doesn't "eject
>>>> -s" (-s required for me) the cd. That means alpine reboots under the
>>>> readonly cdrom with a tmpfs. This works fine, but is surprising if you are
>>>> installing software.
>>>> >
>>>> > Guest additions (mostly not needed by me) are hard to load, since
>>>> they are in /lib/modules/4.9.65-* but the kernel is actually 4.9.59-*. Once
>>>> that is fixed, all good.
>>>> >
>>>> >
>>>> > Virtual's virthardened kernel lacks EFI support (even in module
>>>> form). Also it is worse on VirtualBox EFI since it also lacks video
>>>> drivers. The serial console works, but is hard to use (telnet lacks
>>>> tab-completion, GNU screen requires socat, and only one terminal). Since
>>>> /sys/firmware/efi is not available, setup-disk does not realize it was an
>>>> EFI boot and does everything wrong.
>>>> >
> --
-- Kiyoshi Aman

---

From: Natanael Copa <[email-masked]>
Date: Fri, 1 Dec 2017 18:32:53 +0100

> P.S. Can somebody bump community/virtualbox-guest-additions/APKBUILD 5.1.26

done!

-nc

---

---

From: Natanael Copa <[email-masked]>
Date: Fri, 1 Dec 2017 17:37:22 +0100

On Thu, 30 Nov 2017 09:50:20 -0500

> are missing from the virthardened config.

Thank you. this was very useful.

I am sorry that we didn't have time to get that in before the 3.7.0
release.

I believe it is useful to be able to choose wherever you want use EFI
or legacy bios, even for the virt kernel, so i think we should fix this.

Thank you!

-nc

---