For discussion of Alpine Linux development and developer support

2 2

[alpine-devel] 4.14.18-vanilla breaks framebuffer console on QEMU VMware

Steffen Nurpmeso
Details
Message ID
<20180210221400.LquGt%steffen@sdaoden.eu>
Sender timestamp
1518300840
DKIM signature
missing
Download raw message
Hello!

So i have switched the server to 4.14.18 which does not even
require nopti there, but the console does not show up.
It happens that this is a known issue [1,2,3].  The conclusion of
[3] was

  I disabled CONFIG_FB_SIMPLE and CONFIG_X86_SYSFB for now on master
  and SLE12 branches.

and [1] says

  If you read <https://patchwork.kernel.org/patch/3380911/> there was a
  patched proposed to change it to 'N' and/or to depend on FB_SIMPLE, but
  that patch never made it into linux.

  Nor did <https://patchwork.kernel.org/patch/3368351/> or
  <https://patchwork.kernel.org/patch/3528991/>.

  I tried to contact David Herrmann himself, but never got a reply.

  So I think Debian should disable X86_SYSFB for now, too.

I try it now with the suggestion via grub2 configuration given by
[2]

  This is when using gfxpayload=keep. If I manually switch to
  gfxpayload=text, I don't see this problem - there is no "EFI VGA"
  mentioned in dmesg.

Maybe something to consider.
Ciao!

  [1] https://lists.debian.org/debian-kernel/2016/11/msg00168.html
  [2] https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/1038055
  [3] https://bugzilla.novell.com/show_bug.cgi?id=855821

--steffen
|
|Der Kragenbaer,                The moon bear,
|der holt sich munter           he cheerfully and one by one
|einen nach dem anderen runter  wa.ks himself off
|(By Robert Gernhardt)


---
Unsubscribe:  alpine-devel+unsubscribe@lists.alpinelinux.org
Help:         alpine-devel+help@lists.alpinelinux.org
---
Natanael Copa
Details
Message ID
<20180220185155.42f9cd24@ncopa-desktop.copa.dup.pw>
In-Reply-To
<20180210221400.LquGt%steffen@sdaoden.eu> (view parent)
Sender timestamp
1519149115
DKIM signature
missing
Download raw message
On Sat, 10 Feb 2018 23:14:00 +0100
Steffen Nurpmeso <steffen@sdaoden.eu> wrote:

> Hello!
> 
> So i have switched the server to 4.14.18 which does not even
> require nopti there, but the console does not show up.
> It happens that this is a known issue [1,2,3].  The conclusion of
> [3] was

What hardware is it?

>   I disabled CONFIG_FB_SIMPLE and CONFIG_X86_SYSFB for now on master
>   and SLE12 branches.
> 
> and [1] says
> 
>   If you read <https://patchwork.kernel.org/patch/3380911/> there was a
>   patched proposed to change it to 'N' and/or to depend on FB_SIMPLE, but
>   that patch never made it into linux.

We have FB_SIMPLE enabled, so I don't think this is your problem.

 
>   Nor did <https://patchwork.kernel.org/patch/3368351/> or
>   <https://patchwork.kernel.org/patch/3528991/>.
> 
>   I tried to contact David Herrmann himself, but never got a reply.
> 
>   So I think Debian should disable X86_SYSFB for now, too.

Looks like CONFIG_X86_SYSFB is disabled on Fedora too. I disabled it,
but kept FB_SIMPLE. Can you please test the 4.14.20 kernel and see if
it fixes the issue for you?

-nc

> 
> I try it now with the suggestion via grub2 configuration given by
> [2]
> 
>   This is when using gfxpayload=keep. If I manually switch to
>   gfxpayload=text, I don't see this problem - there is no "EFI VGA"
>   mentioned in dmesg.
> 
> Maybe something to consider.
> Ciao!
> 
>   [1] https://lists.debian.org/debian-kernel/2016/11/msg00168.html
>   [2] https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/1038055
>   [3] https://bugzilla.novell.com/show_bug.cgi?id=855821
> 
> --steffen
> |
> |Der Kragenbaer,                The moon bear,
> |der holt sich munter           he cheerfully and one by one
> |einen nach dem anderen runter  wa.ks himself off
> |(By Robert Gernhardt)
> 
> 
> ---
> Unsubscribe:  alpine-devel+unsubscribe@lists.alpinelinux.org
> Help:         alpine-devel+help@lists.alpinelinux.org
> ---
> 



---
Unsubscribe:  alpine-devel+unsubscribe@lists.alpinelinux.org
Help:         alpine-devel+help@lists.alpinelinux.org
---
Steffen Nurpmeso
Details
Message ID
<20180220195834.Z5kP-%steffen@sdaoden.eu>
In-Reply-To
<20180220185155.42f9cd24@ncopa-desktop.copa.dup.pw> (view parent)
Sender timestamp
1519156714
DKIM signature
missing
Download raw message
Ahoj,

Natanael Copa <ncopa@alpinelinux.org> wrote:
 |On Sat, 10 Feb 2018 23:14:00 +0100
 |Steffen Nurpmeso <steffen@sdaoden.eu> wrote:
 |> So i have switched the server to 4.14.18 which does not even
 |> require nopti there, but the console does not show up.
 ...
 |What hardware is it?

A VM hosted by a German hoster (portunity).
dmesg shows kvm-clock and "VMware VMMouse" as well as QEMU QEMU
USB Tablet and QEMU DVD-ROM.

  ...
 |We have FB_SIMPLE enabled, so I don't think this is your problem.
  ...
 |Looks like CONFIG_X86_SYSFB is disabled on Fedora too. I disabled it,
 |but kept FB_SIMPLE. Can you please test the 4.14.20 kernel and see if
 |it fixes the issue for you?

Works with "gfxpayload=keep":

  [    1.051897] fb: switching to cirrusdrmfb from EFI VGA
  [    1.051952] Console: switching to colour dummy device 80x25
  ...
  [    1.053659] fbcon: cirrusdrmfb (fb0) is primary device
  [    1.057474] Console: switching to colour frame buffer device 128x48
  [    1.064294] cirrus 0000:00:02.0: fb0: cirrusdrmfb frame buffer device
  [    1.073400] [drm] Initialized cirrus 1.0.0 20110418 for 0000:00:02.0 on minor 0

Thank you.

--steffen
|
|Der Kragenbaer,                The moon bear,
|der holt sich munter           he cheerfully and one by one
|einen nach dem anderen runter  wa.ks himself off
|(By Robert Gernhardt)


---
Unsubscribe:  alpine-devel+unsubscribe@lists.alpinelinux.org
Help:         alpine-devel+help@lists.alpinelinux.org
---