For discussion of Alpine Linux development and developer support

4 3

[alpine-devel] Packages for promotion to community

Details
Message ID
<20181222220625.GD1539@homura.localdomain>
Sender timestamp
1545516385
DKIM signature
missing
Download raw message
Hi folks, I would like to see these packages promoted to community if
none are opposed:

- moreutils
- py-beautifulsoup4
- py-flask-login
- py-pygfm

Happy to adopt them if necessary. Cheers!


---
Unsubscribe:  alpine-devel+unsubscribe@lists.alpinelinux.org
Help:         alpine-devel+help@lists.alpinelinux.org
---
Curt Tilmes
Details
Message ID
<CAMv20O9fZq=XFB6t6EVo+DwSEvp2C-AnkxnnBWXt=fmputp-Tw@mail.gmail.com>
In-Reply-To
<20181222220625.GD1539@homura.localdomain> (view parent)
Sender timestamp
1545660244
DKIM signature
missing
Download raw message
I would like to see the Perl 6 packages promoted to community if none are
opposed:
rakudo, nqp, moarvm, zef.

Curt


On Sat, Dec 22, 2018 at 5:06 PM Drew DeVault <sir@cmpwn.com> wrote:

> Hi folks, I would like to see these packages promoted to community if
> none are opposed:
>
Details
Message ID
<20190108190044.GH1023@miku>
In-Reply-To
<20190108184943.109f9a57@ncopa-desktop.copa.dup.pw> (view parent)
Sender timestamp
1546974044
DKIM signature
missing
Download raw message
On 2019-01-08  6:49 PM, Natanael Copa wrote:
> (py-flask-login) needs some cleanup. -%<- Would you like to take
> maintainership of py-flask too while at it?

Patches coming right up.

> (py-gfm has) some checkdepends. Have you verified that all of those
> are already in community? Otherwise we need to move those as well.

I'm actually no longer interested in moving py-gfm to community.


---
Unsubscribe:  alpine-devel+unsubscribe@lists.alpinelinux.org
Help:         alpine-devel+help@lists.alpinelinux.org
---
Natanael Copa
Details
Message ID
<20190108184943.109f9a57@ncopa-desktop.copa.dup.pw>
In-Reply-To
<20181222220625.GD1539@homura.localdomain> (view parent)
Sender timestamp
1546969783
DKIM signature
missing
Download raw message
On Sat, 22 Dec 2018 17:06:25 -0500
Drew DeVault <sir@cmpwn.com> wrote:

> Hi folks, I would like to see these packages promoted to community if
> none are opposed:
> 
> - moreutils
> - py-beautifulsoup4

I have moved moreutils and py-beautifulsoup4 to community.

> - py-flask-login

This needs some cleanup. py2-flask-login depends on py-flask instead of
py2-flask. The correct dependency will be pulled in indirectly, but if
you do: apk add python2 python2 py2-flask-login, you will also get
py3-flask installed, even if you don't really needed it. Same thing
applies to py3-flask-login.

This needs to be fixed so:
 py2-flask-login depends on py2-flask
 py3-flask-login depends on py3-flask

I think we also may need both py2-flask and py3-flask explicitly in the
makedepends.

Would you like to take maintainership of py-flask too while at it?

> - py-pygfm

This have some checkdepends. Have you verified that all of those are
already in community? Otherwise we need to move those as well.

> 
> Happy to adopt them if necessary. Cheers!
> 
> 
> ---
> Unsubscribe:  alpine-devel+unsubscribe@lists.alpinelinux.org
> Help:         alpine-devel+help@lists.alpinelinux.org
> ---
> 



---
Unsubscribe:  alpine-devel+unsubscribe@lists.alpinelinux.org
Help:         alpine-devel+help@lists.alpinelinux.org
---
Natanael Copa
Details
Message ID
<20190108185917.45573813@ncopa-desktop.copa.dup.pw>
In-Reply-To
<CAMv20O9fZq=XFB6t6EVo+DwSEvp2C-AnkxnnBWXt=fmputp-Tw@mail.gmail.com> (view parent)
Sender timestamp
1546970357
DKIM signature
missing
Download raw message
On Mon, 24 Dec 2018 09:04:04 -0500
Curt Tilmes <curt@tilmes.org> wrote:

> I would like to see the Perl 6 packages promoted to community if none are
> opposed:
> rakudo, nqp, moarvm, zef.
> 

rakudo depends on nqp, which seems to be supported on only a limited
set of architectures. We need adjust the arch variable to rakudo and
zef to correspond with this limited set of arches.

Maybe we should have a whitelist of supported architectures instead of
"all" + blacklist the unsupported ones?

rakudo has an explicit dependency of libffi. Is this really needed?
there is an indirect dependency via so:libmoar.so which depends on
so:libffi.so.6. But I don't know if rakudo will dlopen libffi.so.6 (in
which case the explicit dependeny of libffi is correct). Someone need
to investigate this and either remove explicit libffi dependency or add
a comment that explains why its needed.

-nc


---
Unsubscribe:  alpine-devel+unsubscribe@lists.alpinelinux.org
Help:         alpine-devel+help@lists.alpinelinux.org
---