Subject: [alpine-devel] seeking advice of build automation and keeping git synced

From: [email-masked]
Date: Mon, 18 Feb 2019 10:26:58 +0000

hi folks.

I'm attempting to automate my builds of packages, using gitea+drone

Here is a sample build for xeyes

https://gogs.bigyellowfish.com/scrumpyjack/xeyes

The pipeline goes as follows.
When stuff gets pushedi to the above repo, a githook triggers the drone 
build.
Drone uses docker images as a starting point, alpine:edge in this case, 
and you can see the build steps in .drone.yml.
The last bit formats a patch, which cna be sent to the aports mailing 
list.

What I'm struggling with is how to keep that xeyes repo in sync with 
https://git.alpinelinux.org/aports/tree/community/xeyes
so that changes anyone else makes get applied to my local xeyes repo.

Anyone with better git skills than me have any advice?

Perhaps there is a better way of doing this (i'd like to stick with 
drone though)?

--
Not sent from a tablet or smartphone.

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Robert Hencke <[email-masked]>
Date: Mon, 18 Feb 2019 20:39:18 -0500

Hey scrumpyjack,

If I understand correctly, what you want is a process that takes the latest
work from your repository, combines it with the latest work on xeyes in
sports, and builds the result?

Thanks,
Rob

---

From: [email-masked]
Date: Tue, 19 Feb 2019 08:59:53 +0000

>sports, and builds the result?

hi Robert, thanks for asking. Here is a better description:

I make changes to my local xeyes repo, and drone builds the package when I
push the changes. A patch gets created on successfull build and gets emailed
to alpine-aports.

The patch then gets applied to xeyes in the aports tree

At this point both xeyes are identical.

But if you, Robert, modify the xeyes package in the aports tree, i need a way
to pull those changes into my local xeyes repo automatically, so that they are
always in sync.

Does that make sense?

---

---

From: Steffen Nurpmeso <[email-masked]>
Date: Tue, 19 Feb 2019 14:05:57 +0100

[email-masked] wrote in <20190219085953.GD14592@stiletto>:
 |On Mon, Feb 18, 2019 at 08:39:18PM -0500, Robert Hencke wrote:
 |>
 |>If I understand correctly, what you want is a process that takes the \
 |>latest
 |>work from your repository, combines it with the latest work on xeyes in
 |>sports, and builds the result?
 |
 |hi Robert, thanks for asking. Here is a better description:
 |
 |I make changes to my local xeyes repo, and drone builds the package when I
 |push the changes. A patch gets created on successfull build and gets \
 |emailed
 |to alpine-aports.
 |
 |The patch then gets applied to xeyes in the aports tree
 |
 |At this point both xeyes are identical.
 |
 |But if you, Robert, modify the xeyes package in the aports tree, i \
 |need a way
 |to pull those changes into my local xeyes repo automatically, so that \
 |they are
 |always in sync.
 |
 |Does that make sense?

Either "rebase --onto UPSTREAM MYCHANGES-FIRST^ MYCHANGES" or look
out for the git "rerere" command, but which i have never used
myself.  Merge conflicts can still happen of course, i would then
"rebase --abort", stop the automated process and send me a mail.

--steffen
|
|Der Kragenbaer,                The moon bear,
|der holt sich munter           he cheerfully and one by one
|einen nach dem anderen runter  wa.ks himself off
|(By Robert Gernhardt)

---