Subject: [alpine-devel] Should we drop armhf (armv6) support with 3.10 release?

From: Natanael Copa <[email-masked]>
Date: Thu, 4 Apr 2019 11:25:25 +0200

Hi,

I wonder if can drop armhf (armv6) support with the 3.10 release, now
that we have armv7?

In practice it means that we no longer support Raspberry PI 1 and Zero.

We will still support those with alpine v3.9 for another year.

I believe dropping armhf (armv6) will save some resources when it comes
to managing build servers, disk space, spending time on fixing armhf
specific problems.

We may also optimize the vanilla kernel better for armv7, which
currently uses same config as armv6.

What do you think, can we drop armhf for v3.10 or should we wait til
v3.11?

-nc

---
Unsubscribe:  [email-masked]
Help:         [email-masked]
---

---

From: Leonardo Arena <[email-masked]>
Date: Thu, 4 Apr 2019 12:26:57 +0200

> I wonder if can drop armhf (armv6) support with the 3.10 release, now
+1

/eo

---

From: C H <[email-masked]>
Date: Thu, 4 Apr 2019 07:06:30 -0400

>> I wonder if can drop armhf (armv6) support with the 3.10 release, now

I'm new 'round here, but that might be sufficient motivation for a 4.0
release, especially coupled with the other proposed changes -- GCC 9, maybe
the python refactor, etc..

Is there precedent for rolling major version numbers?

---

From: Natanael Copa <[email-masked]>
Date: Thu, 4 Apr 2019 13:30:01 +0200

On Thu, 4 Apr 2019 07:06:30 -0400

> Is there precedent for rolling major version numbers?

We changed from alpine 1.x to 2.x when there was an ABI breaking change
in uClibc.

We changed from alpine 2.x to 3.x when we moved from uClibc to musl
libc.

In both those occasions an upgrade meant a full re-install. Older
packages would not work with new release.

Now, in practice, we do full reinstall every release anyway. `apk
upgrade -U -a` will replace all packages, so major version number roll
does not matter that much.

We have been talking about do 4.0 release with apk-tools 3.0, which will
have incompatible database format. That project is stalled though.

*If* we would ever switch to GNU libc, that would qualify for major
version number roll. But there are no plans for that, and will
hopefully never be.

So basically, the idea with use 3.10 was that we follow something
similar to semver, but I don't have strong opinion there. I think "4.0"
looks better than "3.10". On the other hand "3.11" can be fun. Alpine
Linux 3.11 for workgroups...

 -nc

---

---

From: Corvin Wimmer <[email-masked]>
Date: Sun, 07 Apr 2019 08:51:28 +0000

> On 4. Apr 2019, at 16:25, Natanael Copa <[email-masked]> wrote:
> 
> Hi,
> 

Dear Nathanael, Alpine developers and users,

We have been happily using the armv6 images for our project after switching from Raspbian for 6 months now. 

Alpine has been a breath of fresh air and we would very much like to continue building on top of this unique distribution. 

The fact that Alpine is also designed to run from RAM and is so lightweight makes it a perfect fit for SBCs and other embedded low powered devices. 

Currently we find it especially convenient that an identical image can be built for every Raspberry Pi on the market.

Honestly, the roadmap has taken us by surprise and we might not have chosen Alpine had we known that support for Raspberry Zero was being dropped this soon.

We fully understand that Alpine has limited resources and you want to focus where it matters. 

In my humble opinion, it would be wonderful to see support for alternative architectures such as ARM and RISC be increased rather than reduced. 

We are fully committed to Alpine and plan to upstream patches to installation scripts and continue to help improve Raspberry support where we can.

Please let me know if there are specific resources the project is worried about where we could help. 

I would be delighted to continue working with Alpine for as long as possible. 

In either case, I’d like to extend my thanks to you and the other developers for their contributions.

Regards,
Corvin Wimmer

---

---

From: Carl Chave <[email-masked]>
Date: Mon, 8 Apr 2019 20:45:31 -0400

> The fact that Alpine is also designed to run from RAM and is so lightweight makes it a perfect fit for SBCs and other embedded low powered devices.

+1 from an Alpine newbie who came here specifically for armhf on the pi zero w.

---

---

From: Milan P. Stanić <[email-masked]>
Date: Thu, 4 Apr 2019 16:10:25 +0200

> What do you think, can we drop armhf for v3.10 or should we wait til

Although I don't use armhf anymore, upgraded last box about two weeks
ago, I think that the armhf is used on a lot of small and old SBC's.
Alpine works very well on these old SBC's because it is small, fast and
not memory or CPU hungry as most other non musl distribution are.

I don't have strong opinion on that, but think a lot of people will be
disappointed if armhf vanished from Alpine.

-- 
regards

---

---

From: Kaspar Schleiser <[email-masked]>
Date: Mon, 8 Apr 2019 10:45:31 +0200

Hello,

+1

Kaspar

---

---

From: Oliver Smith <[email-masked]>
Date: Thu, 04 Apr 2019 17:02:00 +0000

Hello Natanael,

I would strongly prefer if we don't drop armhf on such short notice. As
you know, postmarketOS uses Alpine's repositories (with some extra
packages on top). We have device specific packages for each phone /
other target device, and right now there are only 16 armv7 devices
compared to 80 armhf devices.

If we have to drop armhf any time soon (which is understandable
considering the resources you have mentioned), then I would suggest to
do it in 3.11 and explicitly mention it in the 3.10 release notes.

Thanks,
Oliver

---

---

From: Leonardo Arena <[email-masked]>
Date: Thu, 04 Apr 2019 19:17:23 +0200

I did not imagine there was such a large adoption among the phones.

I definitely reconsider my position. :)

Thanks!

---

From: Pablo Rogina <[email-masked]>
Date: Thu, 4 Apr 2019 14:23:26 -0300

+1

---

---

From: "Francesco Colista" <[email-masked]>
Date: Thu, 04 Apr 2019 18:42:58 +0000

+1

.: Francesco Colista
.: Alpine Linux Core Dev Team

---